Support » Networking WordPress » Broken root site admin

Viewing 14 replies - 1 through 14 (of 14 total)
  • EDIT: I also changed an upload path to images, as they were not showing on the website, according to the following:

    1.Go to Super Admin > Sites, hover over the primary blog and click Edit
    2.Change “Upload Path” to wp-content/blogs.dir/1/files (this one was: wp-content/uploads)
    3.Change “Upload Url Path” to /files (this one was empty)
    4.Change “Fileupload Url” to (this one was:

    I think it is one of the three things that is causing the problem…

    *sigh* Don’t do that. Really, don’t screw around with the uploads, they have nothing to do with your admin working (or not working), they have to do with your media, where it’s stored, and what URL it’s access by. It’s supposed to be wp-content/uploads for your main site.

    Don’t assume you know better than WordPress’s default install, unless you’re a core developer. And even then, you’re probably wrong 🙂 I’ve had to rebuild enough sites to know that I don’t know better, and I’ve been at this for a long time now.

    The issues are all down to two likely things:

    1) Plugins
    2) Themes

    Since none of these things happen on clean installs, you’ve basically managed to muck up your site. The best thing you can do is start the normal, standard debugging.

    Turn off all of your plugins. Yes. All. And switch to the TwentyEleven theme.

    Does the issue with saving posts still happen?

    I changed the upload settings because of images not showing on the root site, and that helped. I was also told to check whether AllowOverride is set to All in httpd.conf file (the answer from host was yes), but I just left it at this, since it was working. But it looks like I took a wrong path…

    I have several things going on with the root site that I need / want to fix:

    1) Pagination not working (I get a 404 error on
    2) Root site admin is broken (it saves the information, but it does not go back to the screen, like I mentioned before)
    3) Yoast SEO sitemap is not working (I actually get the same “nothing” screen from point 2, when I enter <thats the URL for the sitemap on the other, not root, blogs>; when I enter something like I get a 404 error – so it looks like something is there, but it is not showing)

    I will be deactivating all the plugins, and testing it on TwentyEleven, according to the post above.

    Thank you.

    I am gonna try to do this one thing at a time, so to come back to the “square one” – images are not showing on the root website after adding them to a post.

    I changed the settings to the origninals, which is:

    Upload Path: wp-content/uploads
    Upload Url Path: <empty>
    File Upload Url:

    #) AllowOverride is set to All in httpd.conf

    #) When I right-click “Properites” on the empty image spot I get the following URL:

    #) This is htaccess file:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            BrowserMatch ^Mozilla/4 gzip-only-text/html
            BrowserMatch ^Mozilla/4\.0[678] no-gzip
            BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
            BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
        <IfModule mod_headers.c>
            Header append Vary User-Agent env=!dont-vary
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE text/css application/x-javascript text/x-component text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon
    <FilesMatch "\.(css|js|htc|CSS|JS|HTC)$">
        FileETag None
        <IfModule mod_headers.c>
             Header set X-Powered-By "W3 Total Cache/"
    <FilesMatch "\.(html|htm|rtf|rtx|svg|svgz|txt|xsd|xsl|xml|HTML|HTM|RTF|RTX|SVG|SVGZ|TXT|XSD|XSL|XML)$">
        FileETag None
        <IfModule mod_headers.c>
             Header set X-Powered-By "W3 Total Cache/"
    <FilesMatch "\.(asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|eot|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|otf|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|svg|svgz|swf|tar|tif|tiff|ttf|ttc|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip|ASF|ASX|WAX|WMV|WMX|AVI|BMP|CLASS|DIVX|DOC|DOCX|EOT|EXE|GIF|GZ|GZIP|ICO|JPG|JPEG|JPE|MDB|MID|MIDI|MOV|QT|MP3|M4A|MP4|M4V|MPEG|MPG|MPE|MPP|OTF|ODB|ODC|ODF|ODG|ODP|ODS|ODT|OGG|PDF|PNG|POT|PPS|PPT|PPTX|RA|RAM|SVG|SVGZ|SWF|TAR|TIF|TIFF|TTF|TTC|WAV|WMA|WRI|XLA|XLS|XLSX|XLT|XLW|ZIP)$">
        FileETag None
        <IfModule mod_headers.c>
             Header set X-Powered-By "W3 Total Cache/"
    # END W3TC Browser Cache
    # BEGIN W3TC Page Cache core
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /
        RewriteRule ^(.*\/)?w3tc_rewrite_test$ $1?w3tc_rewrite_test=1 [L]
        RewriteCond %{HTTP_HOST} ^(www\.)?([a-z0-9\-\.]+\.[a-z]+)\.?(:[0-9]+)?$
        RewriteRule .* - [E=W3TC_DOMAIN:%2]
        RewriteCond %{REQUEST_URI} ^/(001|002)/
        RewriteRule .* - [E=W3TC_BLOGNAME:%1.]
        RewriteCond %{HTTPS} =on
        RewriteRule .* - [E=W3TC_SSL:_ssl]
        RewriteCond %{SERVER_PORT} =443
        RewriteRule .* - [E=W3TC_SSL:_ssl]
        RewriteCond %{HTTP:Accept-Encoding} gzip
        RewriteRule .* - [E=W3TC_ENC:_gzip]
        RewriteCond %{REQUEST_METHOD} !=POST
        RewriteCond %{QUERY_STRING} =""
        RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp-(app|cron|login|register|mail)\.php|wp-.*\.php|index\.php) [NC,OR]
        RewriteCond %{REQUEST_URI} (wp-comments-popup\.php|wp-links-opml\.php|wp-locations\.php) [NC]
        RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|wordpress_\[a-f0-9\]\+|wordpress_logged_in) [NC]
        RewriteCond %{HTTP_USER_AGENT} !(W3\ Total\ Cache/0\.9\.2\.4) [NC]
        RewriteCond "%{DOCUMENT_ROOT}/wp-content/w3tc-%{ENV:W3TC_BLOGNAME}%{ENV:W3TC_DOMAIN}/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" -f
        RewriteRule .* "/wp-content/w3tc-%{ENV:W3TC_BLOGNAME}%{ENV:W3TC_DOMAIN}/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" [L]
        RewriteCond %{REQUEST_METHOD} !=POST
        RewriteCond %{QUERY_STRING} =""
        RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp-(app|cron|login|register|mail)\.php|wp-.*\.php|index\.php) [NC,OR]
        RewriteCond %{REQUEST_URI} (wp-comments-popup\.php|wp-links-opml\.php|wp-locations\.php) [NC]
        RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|wordpress_\[a-f0-9\]\+|wordpress_logged_in) [NC]
        RewriteCond %{HTTP_USER_AGENT} !(W3\ Total\ Cache/0\.9\.2\.4) [NC]
        RewriteCond "%{DOCUMENT_ROOT}/wp-content/w3tc-%{ENV:W3TC_BLOGNAME}%{ENV:W3TC_DOMAIN}/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.xml%{ENV:W3TC_ENC}" -f
        RewriteRule .* "/wp-content/w3tc-%{ENV:W3TC_BLOGNAME}%{ENV:W3TC_DOMAIN}/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.xml%{ENV:W3TC_ENC}" [L]
    # END W3TC Page Cache core

    #) Broken root site admin issue dissapears after changing to TwentyEleven, but at the same time I dont have no issues on any of the other (non root sites) that are using exactly the same theme (I use the same theme, but name it differently, so I am able to edit them separately without a need of using a plugin <I just modify a name on the top of main ccs file>, but the point is that it is not all going from one theme folder, but each site has a separate one)

    #) Sitemap is showin also, after switching to TwentyEleven (again, all other sites use that theme, and there is no issue)

    The other thing is that I think that this theme was working correctly to begin with, and all the issues started after making some Settings changes etc…

    #) I changed the image link to wp-content/uploads and it is still not showing… (I cant edit the previous post)

    #) After entering the image URL into browser address bar I get the following:

    403 Forbidden
    Access to this resource on the server is denied!


    On other sites when I copy the link and go to the URL I get an image in the browser, so it might be some permissions issue somewhere…

    (wp-content/uploads and wp-content/blogs.dir are both set to 751; all the permissions are exactly the same 751 for folders, and 640 for the actual image files in both cases)

    For a non-root site it is for example:

    (and this one would show)

    # # #

    The only thing that I did to the site was changing the root domain name with:

    MySQL Search & Replace Tool

    Then I was experimenting with the following settings, and I think I changed them all back to defaults (I listed the contents of the fields also):

    Permalink Structure: %postname%
    Category Base: <empty>
    Upload Path: wp-content/uploads
    Upload Url Path: <empty>
    Fileupload Url:

    Other than that the site should be in the original state…

    Wow. Your .htaccess is seriously screwed up.

    Since we’re supposed to be testing without any plugins, revwert your .htaccess to one of these:

    Also keep in mind: WordPress’ rewrite rules always go on the bottom. So you should have a layout like this:

    #Begin W3TC
    All that stuff
    # End W3TC 
    # Begin WordPress
    All WP's stuff
    # End WordPress

    I changed the .htaccess file to SubFolder example (my installation is subfolder), and I am in the same spot:

    1) Images don’t show on the website
    2) Admin is broken (it goes to these “nothing” pages; it doesnt apply to all the admin links – some of them work, some of them dont)
    3) Sitemap is not shoiwng (it goes to that “nothing” page also)

    I am not sure what is causing the images issue (although I mentioned something about permissions, like WordPress would be putting them there, but couldnt read them), and points 2 and 3 seem to be theme related (issues disappear after switching to TwentyEleven). The thing is that I need to keep the theme that I am using, as all the websites that I am working on look the same (again, I think that everything was working fine to begin with)

    This is the theme that I am using:

    I made some modifications, but mostly CSS, and I did not change anything that would cause the site not to work correctly (I was only making changes in Network Admin -> Sites -> (root site) Edit -> Settings, and I think that right now everything is set to defaults)

    It’s likely your theme.

    Last Updated: 2009-04-03

    That’s three years, and there have been a lot of changes in WP (including Multisite).

    I changed the theme for a new one and it solved all the issues except for the broken images.

    When I start a new post and click Upload/Insert -> Select Files , I am not showing the image preview (above <Edit Image> button), but I am able to view it after clicking “Edit Image”. When I insert it into post and publish it the image is not showing on the website.

    For the image URL I get the following path:

    …and I am not able to access it directly through this URL in the browser. I get the following error:

    403 Forbidden, Access to this resource on the server is denied!

    When I go to a different site on the installation (non root), I am easily able to access the image through a URL that is given, for example:

    (I would be talking about Media -> Library -> (Edit) -> File URL)

    I think that all the settings are set to default also (Network Admin -> Sites -> (root site) Edit -> Settings).

    Double check that the /wp-content/uploads/2012/06/ stuff actually exists.

    I suspect that it’s all the monkeying around with the uploads that got that one borked :/

    Files are uploaded in the folder. I started changing the settings because the images were not uploading, so it was not working in the first place. I have a feeling I might neet to tall to my hosting about this one…

    FWIW, the wp-content/uploads folders don’t go through the ms-files redirect. That is, your images in are going from that to the ms-files.php page (see the line in the .htaccess? That’s it 🙂 ) and then to

    A link to is a totally direct link, no extra hoops and ladders.

    You don’t have any hotlink protection going on, do you?

    I checked and Hotlink Protection is Disabled (thats in cPanel if somebody else is looking)

    There are other ways to do it (I do it straight up in .htaccess for example), but you’d know if you did ’em 😉

    Yeah, time to ask the host why the 403 on images in that folder.

    Maybe they’re owned by the wrong account?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Broken root site admin’ is closed to new replies.