Support » Plugin: AceIDE » Broken plugin after update to 2.6.0

  • Hi there,

    I’m a long time fan of your plugin, but after I updated it to the latest version, many sites using it just reported it don’t work anymore. The code editor loads blank, in place of the system info it used to show. The file tree loads correctly, but fails to open, create, rename or delete the files/folders listed.

    Any thoughts?

    Best regards,

Viewing 15 replies - 1 through 15 (of 27 total)
  • Same here; after the update to 2.6.0, most (but strangely, not all) of the sites I’m using AceIDE on show identical behavior. More specifically, when attempting to load a file, the POST request to /wp-content/plugins/aceide/src/Ajax.php returns a 403 Forbidden response.

    Form data from the dev tools:

    action: aceide_get_file
    filename: /themes/my-theme-here/css/some-stylesheet.css
    _wpnonce: aea216747a
    Philip Ingram

    (@pingram3541)

    Same, many php files such as a theme’s function.php also load incorrectly as if showing the result of partially executed code. For example php opening tags are stripped out along with comment notation and many php files begin with html.

    Plugin Author shanept

    (@shanept)

    Hi all,

    I have had a look into this. It’s bizarre, I did not have this issue during testing before release, however I am definitely experiencing it now. I have fixed it in my environment, and will push an update ASAP. If you could all test and let me know how this goes, it would be appreciated.

    Thanks for bringing this to my attention!

    Kind Regards,
    Shane

    Hi,

    I have the plugin version 2.6.1. I wanted to use the plugin but I cannot, the first page is black and the files do not open.Same as what it is said above.

    Please fix it, it is the only way I can modify some files in my managed server.

    Best Regards

    Hi Shane,

    I’ve updagraded some different installations from 2.6.0 to 2.6.1 and they still remain unusable; the ones running 2.5.5 are fully functional, by the way.

    Hope it helps you figure it out.

    Kind regards,

    Plugin Author shanept

    (@shanept)

    Hi guys,

    Really sorry to hear that. I have no such issues my side, so I’ve got no idea currently as to what causes the issues you’re having.

    Are you able to provide a screenshot of your browser console, or any other sort of insight as to what may be going wrong from the browser side?

    Thanks

    Sure — do you have an email address I could send these screenshots to?

    Just did some testing, and I’ve still got at least one site that reliably throws this error, even when accessing with a fresh login, caching disabled, in an incognito window.

    Plugin Author shanept

    (@shanept)

    Sure.

    me (at) shane (dot) pt

    Plugin Author shanept

    (@shanept)

    Hi all,

    Has anyone got any more information on this? I haven’t received any emails regarding this yet.

    Thanks 🙂

    Hi Shane, I’ve sent you an e-mail earlier today. I’ve detailed my dev environment as much as I could, check it out when you can.

    Best regards,

    Plugin Author shanept

    (@shanept)

    Hi Andre,

    I have just recieved the email, and have had a look over your site now.
    You have another unrelated issue, but it has helped track down part of the issue.

    As you showed in your email, you are getting a 404 for the resource Ajax.php. The path is correct, however the file is missing. It is not missing from the plugin repository. In fact, you seem to be missing every single PHP file that belongs to the plugin! I’m not sure why this has happened, and I can only imagine that a re-install will fix it, or there is an issue with your server/WP or another plugin deleting these files.

    What plugins do you currently have enabled on your site?

    Thanks

    • This reply was modified 6 months, 3 weeks ago by  shanept.

    That’s not entirely correct. I have lots of php,css,sh files on the plugin directory, however a few are missing for some unknown reason. Had uninstalled AceIDE, deactivated all others plugins, reinstalled and activated ONLY AceIDE, and still the same error remains. Since this is a dev site, not much of a problem; but been unable to use it is a PITA… Here is the plugins list:

    • AceIDE
    • Advanced Custom Fields
    • ACF Content Analysis for Yoast SEO
    • All-in-One WP Migration
    • Custom User Profile Photo
    • Display PHP Version
    • FakerPress
    • Regenerate Thumbnails
    • Simple Featured Image Column
    • What The File
    • Yoast SEO

    On others installations running AceIDE 2.5.5 the plugin works as it should.

    Plugin Author shanept

    (@shanept)

    Thanks for the info.

    Sorry for the confusion, I’m saying that all the PHP files in the AceIDE plugin specifically, are all missing.

    Are you perhaps able to view error logs as you install the plugin? That may give some insight as to what is going on.

    Shane — just sent you an email with some screenshots. Thanks for taking a look at this.

    Plugin Author shanept

    (@shanept)

    So what I can tell from the website @primathon is hosting, is that WP-Engine doesn’t like the plugin. Specifically, they don’t like serving PHP files out of wp content.

    Is WP-Engine hosting a common factor here with everyone else?

    Thanks for your patience

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Broken plugin after update to 2.6.0’ is closed to new replies.