Support » Fixing WordPress » Broken permalinks – 500 Internal Server Error

  • I’m running WordPress 3.3.1 on my own hosted website. I’m a novice to all this, so I don’t write code or anything! But I do use the php client FileZilla, so I’m not too bad. 😉 My website home address ( a flash page, then has the root /blog, which is run on WordPress. I had been using Blogger a my blog platform, so I imported the blogs on there to bring them on to WordPress.

    Because time allowed for it, I spent yesterday working on the blog part of the site. I bought a new theme — ColorWay Theme Pro 2.1.7 by — and used the theme options to add links to the blog homepage. Everything was looking and working great. It must be one of the following actions that has led the permalinks for my blog posts to become broken:

    I created a new page under the title “Blog”, and changed the permalink to direct the page to But I remember going into this, and the blogs worked fine.

    When I had imported my blog posts from Blogger, the tags became part of the “Categories” section on WordPress; so I used the Categories to Tags Converter Importer plugin to fix this. I then created a three categories, “poetry”, “filíocht” and “bàrdachd” (poetry in Irish and Scottish Gaelic), and put my different language poems into these categories. I created another page (“Poetry”), and had hoped to create drop-down menu options under this parent page for the other two language. Again, when I created these wee pages, I changed the permalink to the link to their category page. This didn’t work out as planned, so I just deleted the “Poetry” page and its menu options.

    Then I created a “Gallery” and a “Contact” page, as per the instructions that came with the theme package. The “Gallery” page seems to be misbehaving, but I’m not too bothered about that for now.

    It was at this stage that I noticed that I was getting the 500 Internal Server Error when I went into my blog posts. I thought it was just being tempermental after all the work, and that it would sort itself out. But no, the problem is still there today. I’ve been researching and trying out different things all afternoon, like changing the blog permalinks back to default, but I can’t figure it out. I even contacted my host provider, and they said it was my permalinks that were broken, and that needed to be fixed within WordPress. I’ve been seeing folk talking about the htaccess file, but I’ve no idea what that is or how to get to it.

    Sorry for my lengthy post, but I figured it was best to fill you in on what I was up to in order to diagnose the problem! 😉


Viewing 14 replies - 1 through 14 (of 14 total)
  • Try resetting your custom permalinks back to the default setting via Settings -> Permalinks and renaming the .htaccess file in your root WP folder. If this works, then review Using_Permalinks before setting a custom permalink structure back up again. And stop manually editing permalinks.

    Thanks a million. Whereabouts should the .htaccess file be?

    As in, I can see my wp-admin, wp-content, wp-includes folders, but can’t seem to find the .htaccess file.

    I’ve reset the permalinks back to default, but I’m still having no luck with finding my .htaccess file. What I have noticed since I first posted this is that some of my blog links actually work, but the majority still don’t. That doesn’t really make sense…

    Ensure that your ftp client is configured to show all files. Many ftp clients are configured, by default, to hide .htaccess files. The file will be in your root WordPress folder (ie the one that also holds your wp-config./php file).

    Moderator Mark Ratledge


    Forum Moderator

    You’re on a windows server. Ask your web host if they have the URL Rewrite Module installed. See

    You’re on a windows server.

    Well that would certainly explain a few things…

    Oh aye, should have mentioned that! I’ve forced the FTP client to show hidden files, but still no luck. The file structure goes like this: webapps > SiteApp#### > htdocs, then you have these files:
    – blog
    – tmp
    – wp-admin
    – wp-content
    – wp-includes

    Can’t see the .htaccess file(s) in any of these. :-/

    The thing is, I was using “pretty permalinks” long before this and didn’t have any problem, so I don’t think it has to do with the URL Rewrite Module…

    Moderator Mark Ratledge


    Forum Moderator

    Any .htaccess will be at the same level of wp-admin, etc.

    Ask your host. They have control over the URL Rewrite Module

    I’ll do that first thing on the morrow. Cheers!

    I’ve been in touch with my host, and they’ve said that the URL Rewrite Module is installed and operational. And the .htaccess file is not in the folder with wp-admin, etc. o.O

    Moderator Mark Ratledge


    Forum Moderator

    …the URL Rewrite Module is installed and operational

    I doubt it. Tell your host to fix it.

    Or find a new host: Recommended WordPress Web Hosting

    Try disabling all your plugins, then reverting to the TwentyTen / TwentyEleven theme. If your permalinks work, chances are it’s the new theme that’s thrown something off. I’ve had exactly the same issue with another blog (which I’ve not fixed yet).

    Your .htaccess file should be in the root of your WordPress installation – your /blog folder from what I can see. Have a look in Settings and see where you’re telling it your WP installation folder is. Also check the root of your website in case it’s been put there in a previous install. If you don’t have a .htaccess file there WordPress should automatically create one for you. To force it to do so, go and change your permalinks structure (doesn’t matter which option you choose) then hit save. Check and see if a .htaccess file has been created in your WordPress directory.

    You may see an infobox saying that WordPress doesn’t have permissions to .htaccess. That’s where I got to, got my hosting provider to check and they confirmed all permissions were fine, my next stage is to reinstall WordPress.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Broken permalinks – 500 Internal Server Error’ is closed to new replies.