• Resolved emthreex

    (@emthreex)


    Hi,
    Opening an old post with the old TOC block resulted in a complete failure to load the Gutenberg editor (empty white page appears). The error in the console is: “ReferenceError: align is not defined” Here is the full callstack:
    https://imgur.com/a/kCFEeBs
    I think it is missing “var align = attributes.align === undefined ? ‘none’ : attributes.align” or something similar.
    Plugin version 2.9.2
    WordPress 5.7.2.
    Thanks,
    Emthreex

    p.s. I think “headings” would be undefined too

    • This topic was modified 2 months, 1 week ago by emthreex.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author htmgarcia

    (@htmgarcia)

    Hi @emthreex,
    how old is the post? Is possible the TOC was added with a very old version of the plugin?

    A quick way to re-do the TOC block is by deactivating PublishPress Blocks, then edit the post to remove TOC block. As last steps activate back the plugin and insert the block.

    Regards

    Thread Starter emthreex

    (@emthreex)

    Cannot be 100% sure, but it must have been 2.4.7.

    Plugin Author htmgarcia

    (@htmgarcia)

    Checking the changelog from 2.4.7, we don’t have changes related to TOC block.

    Regards

    Thread Starter emthreex

    (@emthreex)

    Well…I guess it will remain mystery. At least we know how to deal with it if it happens again.

    Cheers,
    Emthreex

    Plugin Author htmgarcia

    (@htmgarcia)

    Thanks for using PublishPress Blocks, @emthreex !

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.