WordPress.org

Support

Support » Themes and Templates » Broken my theme/site. Need help!

Broken my theme/site. Need help!

  • twamoran
    Member

    @twamoran

    Hi,

    First of all this is totally my fault! I was trying to add some code into the sidebars.php of my theme (Carrington-blog) and when I hit refresh it came back with this error message:

    Parse error: syntax error, unexpected T_STRING in /home/twamoran/urbanghosts.com/wp-content/themes/carrington-blog/functions/sidebars.php on line 30

    All I’d done was hit return three times to create three blank lines then pasted the code in for the ad in. When it didn’t work, I took it out and returned it to how it was before (or so I thought!). That’s when the error message (above) came up. I checked out Line 30 and couldn’t see a problem. But now I can’t get into the site at all, or even the dashboard. So its pretty much screwed!

    I know I should have copied the code before I made changes and have learnt the hard way. Is there anything I can do to fix this? I’d really appreciate any help whatsoever…

    Cheers,

    Tom

Viewing 7 replies - 1 through 7 (of 7 total)
  • According to google you embedded some quotes, breaking strings.

    Something like this:

    "this is "the text"
             ^

    Peter

    twamoran
    Member

    @twamoran

    Thanks Peter. What can I do to correct this, since I can’t even log into the dashboard as a result?

    ftp?

    Peter

    btw, it could also be that you removed a semicolon (also according to Google)

    Peter

    twamoran
    Member

    @twamoran

    Sorry mate, I’m pretty new to all this so really don’t know much about the technicalities of it. I have Core FTP which I’ve used for a previous blog, but that was with an earlier version. With my latest blog done through WordPress 2.8, I’ve not used the ftp at all. I’ve downloaded the themes and plugins straight from the dashboard…

    but how did you get wordpress on the site in first place?

    Peter

    twamoran
    Member

    @twamoran

    I just signed up with Dreamhost and then did a one-click install of WordPress. After that I activated the theme from the default options in the dashboard.

    I actually just got an email from Dreamhost and they’ve managed to sort it so panic over!

    Thanks a lot for helping out, Peter. I’ll probably be back on this help forum before long!

    Cheers,

    Tom

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Broken my theme/site. Need help!’ is closed to new replies.