Support » Plugin: Wise Chat » Broken messages in the UI

  • Resolved Martin Krcho

    (@martinkrcho)


    I noticed an issue with the localized messages. When they contain letter with accents they don’t show properly. For example the message “Napíšte svoju správu…” changes after sending a message to “Napíšte svoju správu…”. I believe this is because of the way all the JS options are processed (and encoded) in WiseChat::getRenderedChat.

    My solution is to add the couple of lines belows after line 267. Can you please consider adding this to the next release? Have a look at WP_Scripts::localize() and see how the data passed to wp_localize_script is being handled.

    Thanks

    
    //	mkrcho, 20161003: all the messages in the JS options need to be decoded
    //	@see WP_Scripts::localize()
    foreach ($jsOptions['messages'] as $key => $jsOption) {
    	$jsOptions['messages'][$key] = html_entity_decode( (string) $jsOption, ENT_QUOTES, 'UTF-8');
    }
    //	mkrcho end
    
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Marcin

    (@marcinlawrowski)

    Hi,

    Thank you for your feedback and the solution. I will definitely consider adding this in the next release. Thanks again!

    Best regards
    Marcin

    Plugin Author Marcin

    (@marcinlawrowski)

    This was added in 2.4.2.

    Thank you

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Broken messages in the UI’ is closed to new replies.