[resolved] Broken links to images, admin bar, post body input after 3.2.1 update (8 posts)

  1. fritzfeger
    Posted 4 years ago #

    I have a subfolder install, which after updating to 3.2.1 has a couple of issues.

    First, images are not shown. To be more specific, images in my root blog are shown, and images put into PageLines are shown too. But in mapped blogs, both the WP media library and in the NextGEN Gallery return a 500 error (internal server error). It's the domain mapping causing that problem, because if I manually type in the "true" address (with wp-content/blog.dir/ etc.; I'm all default names), the image is found.

    Here's an example: http://vollgas-bioenergie.de/2011/05/maisanbau-in-deutschland-fnr-de/

    In the admin area, thumbnails of NextGEN Galleries are displayed, thumbnails in the media library are not displayed.

    Secondly, in the admin area the "new post" page doesn't display the text input field (the post title input field is displayed though), and the admin bar is not shown properly, i.e. instead of horizontally at the top of the page it is shown vertically below everything.

    Here's my .htaccess file:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    The multisite installation is strictly along the codex tutorial and Otto's tutorial, and everything worked fine with 3.1.x. I replaced all files except .htaccess and wp-config.php manually, I turned all plugins off and on again. I have a "managed server" with no full access at http://1und1.de, thus no info on AllowOverride = All or jquery version, but, as I said, everything worked just fine with 3.1.

  2. Check and see if httpd.conf has allowoverride set to all. That;s usually where the hangup is.

  3. fritzfeger
    Posted 4 years ago #

    Thank you Ipstenu! Being a shell novice I have finally figured to find and view and edit my httpd.conf. Seems as if my whole WP install is non-existent there! I mean, apart from the above mentioned errors, my blogs are live and working... should I add a VirtualHost manually? The three domains addressed in that file are relatively old ones; I have created many more since, just wondering.

    This is my httpd.conf:

    ScriptAlias /cgi-bin/ /kunden/homepages/38/d30796553/htdocs/cgi-bin/
    ServerAdmin webmaster@fritzfeger.com>
    <VirtualHost sabinedoering.de>
    ServerName sabinedoering.de
    ServerAlias sabinedoering.de
    DocumentRoot /kunden/homepages/38/d30796553/htdocs/SabineDoering
    ScriptAlias /cgi-bin/ /kunden/homepages/38/d30796553/htdocs/SabineDoering/cgi-bin/
    ServerAdmin webmaster@sabinedoering.de>
    <VirtualHost verhovec.de>
    ServerName verhovec.de
    ServerAlias verhovec.de
    DocumentRoot /kunden/homepages/38/d30796553/htdocs
    ScriptAlias /cgi-bin/ /kunden/homepages/38/d30796553/htdocs/cgi-bin/
    ServerAdmin webmaster@verhovec.de>
    <VirtualHost philipphaagen.de>
    ServerName philipphaagen.de
    ServerAlias philipphaagen.de
    DocumentRoot /kunden/homepages/38/d30796553/htdocs/philipphaagen.de
    ScriptAlias /cgi-bin/ /kunden/homepages/38/d30796553/htdocs/philipphaagen.de/cgi-bin/
    ServerAdmin webmaster@philipphaagen.de>

    Host support asked me also to check my php.ini, which is only this one line:

    memory_limit = 128M

  4. fritzfeger
    Posted 4 years ago #

    Support said I can view but not edit the httpd.config; it's a "managed server". He advised me to mention here that WordPress doesn't reside in the htdocs directory, but in a subdirectory of it. BUT before the update everything was fine, so I'd be surprised if this was the point. Rewrite Base / did work previously.

    Since 3.2.1 sort of kills my blogs, should I go back to 3.1?

  5. No no, you're not looking at the right thing.

    Since you're on a managed server, tell your HOST 'Can you check if allowoverride is set to ALL for my accounts?'

  6. fritzfeger
    Posted 4 years ago #

    I was looking at the right thing, or rather Jens Scherbl of http://webninjas.net/ was, all thumbs up. There was actually an erroneous .htaccess file. Not in the root directory, but in the include directory, where the memory limit was raised. This is however impossible when the installation uses fastCGI. I have a php.ini which does the job, but this of course did not prevent the 500 error. Thank you all for your commitment!

  7. The ... include directory? I'm afraid to ask where that was.

  8. sabinsabin
    Posted 4 years ago #

    What was the solution here? what was wrong with the .htcaccess?

    I have the same problem after upgrading to 3.2.1 All the images are broken but the link is correct: For instance even the default theme image:

    is the correct link and I can see the file in the FTP Client, but shows nothing. My whole website looks like a text file, where'd the theme features go?!


Topic Closed

This topic has been closed to new replies.

About this Topic