Support » Plugin: Asset CleanUp: Page Speed Booster » Broken Layout Elements upon Installation

  • Resolved lanab87

    (@lanab87)


    Hi there!

    I’ve recently installed the plugin (I’m still figuring it out so bear with me) and I was just about to begin optimizing the settings for my site, however I noticed that upon installation the plugin has broken certain layout elements? I’m not sure why this would happen, as I haven’t actually gone in and begun telling it which scripts not to load yet, so it’s not an issue of turning off the wrong styles… Could it be a compatibility issue with another plugin, or maybe a setting which is turned on automatically which I need to switch off?

    Thank you – any help will be greatly appreciated!
    Thanks,
    Lana

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Oh – I just noticed, in addition to certain broken layout elements I am also seeing some icons not presently loading on the following pages;

    https://www.fisherglen.ca/veterinary-services/
    https://www.fisherglen.ca/about-us/

    I may uninstall the plugin for now until I hear your recommendations just to keep the live site as it’s supposed to be, but if you need it to be installed to diagnose the issue just let me know and I will do that!

    Cheers,
    Lana

    Plugin Author Gabe Livan

    (@gabelivan)

    @lanab87 it would be good if you can make some print screens with the broken layouts. Also, if you load https://www.fisherglen.ca/?wpacu_no_load (notice the query string), it will load the page as if Asset CleanUp is deactivated (even though it will be active in the Dashboard). It’s good for testing without having to keep activating and deactivating the plugin from the “Plugins” page.

    Are you sure the plugin wasn’t installed before and you reactivated it? Perhaps a developer used it months ago and the settings were kept in the database and when you reactivated the plugin, those setting took effect. You’re using W3 Total Cache in combination with Autoptimize. You have to be careful when activating similar options like Minify/Combine from both plugins as it could lead to conflicts.

    2nd update: apologies, I just fixed the icons issue; it was unrelated.

    Plugin Author Gabe Livan

    (@gabelivan)

    @lanab87 cool, please check the previous message I left as I’d like to know more about the broken layout issue.

    (Sorry if this is a dumb question but can you upload images here? I’m not seeing an attachment button.)

    In the meantime, some more information in case this helps… So after realizing that the icon issue was unrelated, it turns out the homepage is actually the only page that has this bug, despite the fact that other pages have this same layout element. I was able to fix it by switching on the option “Do not apply any CSS & JavaScript settings (including preloading, “async”, “defer” & any unload rules) on this page” – however then I uninstalled again, because I wasn’t sure if that meant it was also removing defer rules from other plugins?

    Okay here you go – I just uploaded it to my domain so I could link it over.

    So the layout element is a container divided up into halves, with half being an image slider and the other half some sort of text based element. For some reason it’s only the one on the homepage that seems to have been broken upon installation;

    Correct:
    https://www.fisherglen.ca/wp-content/uploads/2019/09/Capture-correctlayout.png

    Bug:
    https://www.fisherglen.ca/wp-content/uploads/2019/09/Capture.png

    Plugin Author Gabe Livan

    (@gabelivan)

    @lanab87 I’ve checked your homepage and the print screens and this issue is related to Autoptimize. When it’s disabled on-page request like this: https://www.fisherglen.ca/?ao_noptimize=1 – the layout is not broken anymore and the browser’s console reports fewer errors as well (consider checking the console when you access the page loaded with Autoptimize https://www.fisherglen.ca/ page). You can disable JS optimization from Autoptimize and enable the one from Asset CleanUp. If you still get the same issue, then some files are just not combinable/minifiable and need to be excluded from any caching/changes.

    I was able to fix it by switching on the option “Do not apply any CSS & JavaScript settings (including preloading, “async”, “defer” & any unload rules) on this page”

    You basically disabled assets (CSS/JS) unloading for the homepage. If it fixes it as you claim, then it’s very likely you’ve unloaded a wrong JavaScript file that is needed (it should have been kept loaded) that eventually caused this.

    however then I uninstalled again, because I wasn’t sure if that meant it was also removing defer rules from other plugins?

    No, if the option is ON, defer rules from other plugins are not altered in any way.

    Plugin Author Gabe Livan

    (@gabelivan)

    @lanab87 is everything clear about this? Let me know if I can further assist you or I can mark this topic as “solved”.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.