WordPress.org

Forums

WP Statistics
[resolved] Broken! Latest Update Mess Up (14 posts)

  1. Neap.Tide
    Member
    Posted 11 months ago #

    Hi! I have been using this plugin for past two months and it was working fine till this latest update. Now, visitors, visits and search engine referrals all are showing 0, no browsers information displaying, hits statistics charts is blank, search engine referrals info and search words have stopped functioning. I also tried to download the plugin from here and it gave me the error while downloading that file is corrupted. 20 hours have already past after updating and stats have not given any response yet. I tried deactivating and reactivating it but no luck either.

    https://wordpress.org/plugins/wp-statistics/

  2. Greg Ross
    Member
    Plugin Author

    Posted 11 months ago #

    Make sure your running the latest version 7.0.2 and then check your configuration settings to make sure the exclusions tab is correct.

  3. Neap.Tide
    Member
    Posted 11 months ago #

    I am already using latest version. The stats have refused updating since the last update of plugin.

  4. Neap.Tide
    Member
    Posted 11 months ago #

    Exclusions tabs are correct. No problem there.

  5. Greg Ross
    Member
    Plugin Author

    Posted 11 months ago #

    Are you seeing any errors in your PHP or web server logs?

  6. Neap.Tide
    Member
    Posted 11 months ago #

    No. There are no errors. But I can say with surety that this plugin has been utilizing too much system resources due to a lot of features enabled at once. May be the next update will fix the problem. Till then, I am temporarily disabling this plugin.

  7. Neap.Tide
    Member
    Posted 11 months ago #

    I have another website hosted on the same server and I am using the same plugin there. I updated that and it is working fine for that. No crashing.
    I remember, when I was updating this plugin on current website, update failed. I retried and the update was successful but this problem started which I have mentioned above.
    Plus there is a recommendation that if you remove the 'user manual' files from the package, that will decrease the package size. You can provide the manual separately.

  8. Greg Ross
    Member
    Plugin Author

    Posted 11 months ago #

    Delete the plugin and do a fresh install, perhaps something is corrupted in the current one. 7.0.3 will be out later tongight, you might want to wait until then do it.

    The admin files are only a few meg in size, and the whole plugin is under 11 meg. If your that tight for space your probably going to have other issues on your site anyway and need to add some more space.

  9. Neap.Tide
    Member
    Posted 11 months ago #

    No. I don't have storage issue. I was just saying because large package files when directly downloaded on server may cause issues while unpacking if servers are already under heavy load. That's just my opinion.

    Besides, I will wait for that update and try to update it. Update might fix the problem without reinstalling.

  10. Neap.Tide
    Member
    Posted 11 months ago #

    A little quote from reply sent by my web hosting provider after I contacted them about the problem. That will be useful for plugin admins:

    "As for plugin, we suppose that it is wp-statistics, because there are many fresh PHP errors related to this plugin. You can find them in the error_log file located in the public_html directory of your account. You can contact web developer to resolve the issue with that, because it is related to code debugging, which we do not provide."

    I have checked that now and there is a long long list of errors associated with this plugin. :)

  11. Neap.Tide
    Member
    Posted 11 months ago #

    Thanks for the quick fix. After 7.0.3 update, the problem has resolved and plugin has started working again.

  12. Neap.Tide
    Member
    Posted 11 months ago #

    I have been observing that the links fly off the tab space on 4:3 screen. That happens with other tabs as well on small screen like mobile phone. May be you should fix that also. That is happening since the day I am using this plugin.
    http://i60.tinypic.com/2i2ma8.png

  13. Greg Ross
    Member
    Plugin Author

    Posted 10 months ago #

    Long standing issue, I've committed a fix to svn, just needs some testing.

  14. Neap.Tide
    Member
    Posted 10 months ago #

    Good work. Update 7.1 has also fixed the overflow issue which I mentioned previously. Plus I am now observing that this plugin is no more putting load on hosting server. My website (Benign Blog) is now running smoothly without stressing the system. Otherwise, I was considering to enable CloudFlare for it as recommended by my hosting provider. But now, I can postpone that idea. :)

    Thanks Greg for your efforts.

Reply

You must log in to post.

About this Plugin

  • WP Statistics
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.