Support » Plugin: WP Photo Album Plus » Broken in WP 3.5 (RC1) – missing arguments

  • Resolved monkeypigs

    (@monkeypigs)


    Just downloaded and activated this and get
    Warning: Missing argument 2 for wpdb::prepare(), called in /home/monkey/public_html/blog/wp-content/plugins/wp-photo-album-plus/wppa-album-admin-autosave.php on line 26 and defined in /home/monkey/public_html/blog/wp-includes/wp-db.php on line 990

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/monkey/public_html/blog/wp-content/plugins/wp-photo-album-plus/wppa-common-functions.php on line 904 and defined in /home/monkey/public_html/blog/wp-includes/wp-db.php on line 990

    Missing argument 2 for wpdb::prepare(), called in /home/monkey/public_html/blog/wp-content/plugins/wp-photo-album-plus/wppa-album-admin-autosave.php on line 261 and defined in /home/monkey/public_html/blog/wp-includes/wp-db.php on line 990

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Yes, i know, i am working on it.

    They (the wp core guys) want that we use prepare in all db queries for safety reasons, but now, by wp 3.5 it is no longer allowed to have a prepare without vars (like in sprintf() ).

    I modified approx 40 times, introduced new typos etc..

    In a few days i will release a fixed version. need more testing.

    Thanx for the report.

    Great stuff, look forward to it!

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Fixed 4.8.6

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Broken in WP 3.5 (RC1) – missing arguments’ is closed to new replies.