Support » Plugin: File Gallery » Broken in current wordpress?

  • Resolved mxv

    (@mxv)


    With the new update to WordPress this plugin seems to not work anymore.

    Trying to select only a few images to put in a gallery in a post will post all the images uploaded in the media gallery for that particular post. Removing by hand the numbers of the unwanted images results in the gallery still not showing the proper photos in the gallery that you selected.

Viewing 15 replies - 1 through 15 (of 19 total)
  • That one had the same problem. I select 3 photos (of the 25 that I uploaded) and it lists them all in the gallery instead of just the 3 I picked.

    mxv, I put a fresh 17-RC3, took 3 images from my library of 200 and put them on a post as a gallery. Only the 3 are shown, as expected. Please explain in more detail how to reproduce your issue so it could be fixed.

    Here’s how I did it.

    Start a new post

    Upload a bunch of photos to this post. (I uploaded about 30 but probably doesn’t matter)

    In Visual post editor select a few photos (i was selecting 3 or 6) by checking the boxes. (using HTML editor yielded the same results btw)

    Click the insert as gallery button. I had it set to thumbnails opening up the file (cuz i use a pretty photo plugin for viewing the gallery) and order being random.

    Notice now when you see where it inserted the gallery in your post it will have every photo id listed to include in the gallery regardless of the fact you only selected a few of them to include.

    Hi there,

    Iยดve noticed the same problem. Every time I try to put some image in the post via single file function, all images are inserted. When I use the insert as gallery function the same happens and all attached images are inserted, regardless of the checked ones.

    Hope there will be an update soon cos we love to use this plugin.

    Guys, did as you said. The insert image/gallery works fine, just when you click to focus on the editor to put stuff where you want, whatever you have checked gets unchecked, which by default for a gallery means insert all (and for single inserts none). To see this, click on few images and immediately click on insert ‘a gallery’ button (do NOT click on the editor). Update and preview and it will work as expected. Now, go to HTML view, and for a filtered gallery you will always see something like this:

    [gallery include="599,600,601" link="file" linkclass="thickbox"]

    The include parameter contains the ID’s being shown for a given gallery. When the insert all issue is happening to you, the code inserted is something like this instead:

    [gallery link="file" linkclass="thickbox"]

    Which by default are all post attachments.

    What the dev needs to fix is an usability issue. When the focus is lost from the file-gallery, do not reset the checkboxes state.

    Hi alx359,

    no, that`s not the problem. The focusing issue is standard behaviour. We always did it in the following order:
    1. positioned the caret in the editor where the image or gallery should go
    2. checked the image in the attachment list
    3. pressed the insert button
    So this is not a new issue since the update.
    But following the above order it still inserts all images regardless of the checked ones.
    By the way our wordpress version is 3.2.1 and the plugin version is 1.6.5.4 .

    Regards,
    fundf

    Plugin Author Aesqe

    (@aesqe)

    @fundf: please try out version 1.7-RC4 until v1.7 full isn’t out, thanks! ๐Ÿ™‚

    http://wordpress.org/support/topic/file-gallery-v17-rc4-download

    Same issue with 1.7-RC4 on WordPress 3.2.1
    Inserts ALL images, whatever is checked in the file gallery.

    Kind regards from Austria,
    eliZZZa

    Same problem here. The latest RC does not solve the problem.

    I take it back. The latest RC did work for me, but I failed to remove the previous release properly.

    Plugin Author Aesqe

    (@aesqe)

    @elizzza: unfortunately, I can’t reproduce the problem with the 1.7-RC4 version of the plugin :/

    Please try deactivating and then reactivating plugin if you haven’t already, as there are options that need to be updated with the plugin, and they will only be updated on activation.

    Let me know if it works.

    Thanks! ๐Ÿ™‚

    Hey has a solution for this been implemented yet?
    I don’t want to deactivate the plugin and then reactivate it if it doesn’t solve the issue.

    My client has a enormous gallery section and I don’t want to risk messing anything up unless it works.

    I am having the same problem and its for a enormous website with a ton of file-gallerys here:

    http://www.capedwonder.com
    I am really scared to update to V1.7 if there is any chance it can screw up the current file structures but I am hosed because my client needs to update for some Superman Convention(dorky I know).

    This is the one downside of WordPress is updating.

    Plugin Author Aesqe

    (@aesqe)

    for now, until 1.7 is finally released, please update to v1.6.5.5

    it is basically the same as v1.6.5.4, but it works with WP 3.2 and also fixes three big, annoying bugs with Internet Explorer

    – correct position in editor when inserting content
    – update of gallery shortcode (instead of deletion) when gallery placeholder is clicked
    – File Gallery metabox items editing buttons visibility CSS bug

    there should not be any problems with the upgrade, just make sure you clear your browser cache so the new javascript files get loaded properly!
    I should have forced it via ‘version’ attribute when loding the script – is that worthy of a new version? should I release it immediately? dammit ๐Ÿ˜

    please let me know here if something breaks on your setup (although it shouldn’t)

    thanks,
    Aesqe

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Broken in current wordpress?’ is closed to new replies.