Support » Plugin: Admin Menu Editor » Broken in 3.2?

  • Hi,

    In 3.2 I get:

    Warning: require(/home/xxxxxxxx/public_html/wp-includes/class-json.php) [function.require]: failed to open stream: No such file or directory in /home/xxxxxxxx/public_html/wp-content/mu-plugins/admin-menu-editor/includes/shadow_plugin_framework.php on line 21

    Fatal error: require() [function.require]: Failed opening required ‘/home/xxxxxxxx/public_html/wp-includes/class-json.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/xxxxxxx/public_html/wp-content/mu-plugins/admin-menu-editor/includes/shadow_plugin_framework.php on line 21

    Any ideas?

    Mark

Viewing 5 replies - 1 through 5 (of 5 total)
  • My apologies, apparently my site had somehow been reverted to a backup using an older version of the plugin. With the current version it seems to work fine so far…the fatal error is gone.

    Thanks,

    Mark

    Hi,

    I just updated to WordPress 3.2 and received this error msg. I deleted the plugin from the MU folder and re-installed but got the error msg again. Is there a version that is compatible with 3.2? Thx

    Plugin Author Janis Elsts

    (@whiteshadow)

    Version 1.1.3 should work fine with 3.2. Is that the one you tried?

    I am not sure what I have done…everything was working perfectly…then I went to add a new option to the menu and when I clicked save…
    I got “You do not have sufficient permissions to access this page.”

    Now I can’t access the plugin settings at all…help..this was a great plugin doing exactly what I needed…

    I have tried to deactivate, uninstall reinstall…

    Now what?

    Plugin Author Janis Elsts

    (@whiteshadow)

    Try resetting your menu configuration. To do that that, activate the plugin and go to:
    http://example.com/wp-admin/?reset_admin_menu=1

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Broken in 3.2?’ is closed to new replies.