WordPress.org

Forums

Eazyest Gallery
[resolved] Broken images on single WP subfolder install with wp-content in main folder (17 posts)

  1. klihelp
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,

    Images are broken on subfolder WordPress install and with custom wp-content root.

    Hope this helps, the WP install folder structure is:
    /wp/
    /wp-content/
    /index.php
    /wp-config.php

    http://wordpress.org/extend/plugins/eazyest-gallery/

  2. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    Ok thanks, I have tested with a custom wp-content root, but not combined with WordPress in a subfolder.

  3. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    This issue is fixed in trunk

  4. klihelp
    Member
    Plugin Author

    Posted 2 years ago #

    The issue is still there with RC7.

    Broken image links on one side only, admin or front-end.

    Tested the gallery root setting with:
    wp-content/gallery/
    and
    ../wp-content/gallery/

  5. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    ../wp-content/gallery/ is actually now my development server setup.
    I can't reproduce this error.

  6. klihelp
    Member
    Plugin Author

    Posted 2 years ago #

    Image urls are still broken on subfolder WordPress install and with custom wp-content root. (using RC9)

    /wp/
    /wp-content/
    /index.php
    /wp-config.php

    Observations - with EZG setup /wp-content/ftp/

    1. Expected to create folders inside in /wp-content/ftp/, but folders created inside /wp/wp-content/ftp/
    2. Folders not getting indexed from /wp-content/ftp/, only from /wp/wp-content/ftp/

    ps: Everything works with /wp/wp-content/ setup (wp-content root inside /wp/ subfolder)

  7. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    if you have this setup, the gallery folder should be ../wp-content/ftp
    The gallery folder is relative to ABSPATH, the WordPress folder.
    May need some clarification in the settings page...

  8. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    (trunk) Sttings screen now shows the file system path to your gallery folder.

  9. klihelp
    Member
    Plugin Author

    Posted 2 years ago #

    This issue is still there using the plugin final v.0.1 version.

    Your gallery folder: content/gallery
    Relative to your WordPress installation.
    Your current setting maps to D:/www/_test/wordpress-latest-plugin-test/wp/content/gallery/
    
    The plugin uploads the images to that directory,
    but broken images are pointing outside /wp/ subdirectory, because the /wp-content/ is outside /wp/ directory.
    -> _test/wordpress-latest-plugin-test/content/gallery/

    With different setting:

    Your gallery folder: ../content/gallery
    Relative to your WordPress installation.
    Your current setting maps to D:/www/_test/wordpress-latest-plugin-test/content/gallery/
    
    The plugin uploads the images to that directory,
    but broken images are pointing to one directory higher
    -> _test/content/gallery/
    (missing main website folder)

    Here is a screenshot with the gallery path settings:
    http://qikr.co/files/pics/e/ezgsetting61943.png

  10. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    ok I'll check again.
    What are your General URL settings?

  11. klihelp
    Member
    Plugin Author

    Posted 2 years ago #

    Website url:
    http://localhost.com/www/_test/website

    WP install directory structure
    (based on https://github.com/markjaquith/WordPress-Skeleton)
    D:/www/_test/website/wp/
    D:/www/_test/website/wp-content/
    D:/www/_test/website/index.php
    D:/www/_test/website/wp-config.php

  12. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    WordPress Address (URL) vs Site Address (URL) ?. In. Settings.

  13. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    please try trunk

  14. klihelp
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks, now images are displayed correctly on WordPress subfolder install with custom /wp-content/ outside the /wp/ subfolder.

    Both URLs are the same.
    WordPress Address (URL)	: localhost.com/_test/website
    Site Address (URL)	: localhost.com/_test/website
  15. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    Hm, the WordPress Address should have been localhost.com/_test/website/wp/
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  16. klihelp
    Member
    Plugin Author

    Posted 2 years ago #

    The setup is based on this setting:
    https://github.com/markjaquith/WordPress-Skeleton

  17. Marcel Brinkkemper
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, you said so, but this may break more plugins, because they rely on the site URL.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Eazyest Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic