Support » Plugin: Amazon AWS CDN » Broken Images

  • Resolved Snobs

    (@snobs)


    Hi,

    Not sure what I’m doing wrong but after setting this up, most of my images are broken.

    Could you help?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author luckychingi

    (@luckychingi)

    Can you share the website address? @snobs

    Here it is: https://modeducation.info

    A few images are alright, most are broken.

    Plugin Author luckychingi

    (@luckychingi)

    seems like a permission issue on the uploads folder
    https://modeducation.info/wp-content/uploads/2019/04/colorado-state-logo.jpg gives the error
    Error 403 - Forbidden. You don't have permission to access the requested resource. Please contact the web site owner for further assistance.

    Stylesheet from AWS CDN works https://modeducation.info/wp-content/themes/mod/assets/css/minified/menu-animation.min.css?ver=1.8.1 & https://d3v9742biym9rk.cloudfront.net/wp-content/themes/mod/assets/css/minified/menu-animation.min.css?ver=1.8.1

    Please check the folder permission on the uploads folder

    Hi,

    The uploads folder has the permission 0755.

    What should i change it to?

    Plugin Author luckychingi

    (@luckychingi)

    Check the error log, maybe that will tell the reason.

    Disable AWS CDN to confirm if the plugin is causing this issue.

    Yeah, it works after I disabled the CDN.

    I even had to create a new distribution, and still faced the same issue of broken images.

    Thanks for your help though, I’ll keep trying to resolve it.

    Plugin Author luckychingi

    (@luckychingi)

    Thanks the update, let me know if you need my assistance.

    Resolved it 🙂

    I had hotlinking enabled on the server, this was what caused the broken images.

    Disabled hotlinking and it works good.

    However, I’ve encountered another problem, lol.

    Icons are broken, and the site is built with Elementor.

    Plugin Author luckychingi

    (@luckychingi)

    I think its CORS headers issue

    Refer to this article https://github.com/fontello/fontello/wiki/How-to-setup-server-to-serve-fonts

    LMK if this helps

    Awesome.

    Works great now.

    Thanks a lot.

    Plugin Author luckychingi

    (@luckychingi)

    Thanks for the update @snobs

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Broken Images’ is closed to new replies.