Support » Plugin: WP Offload S3 Lite » Broken Images

Viewing 6 replies - 1 through 6 (of 6 total)
  • DistressedPro

    (@distressedpro)

    If anyone else is having this problem you need to change the Domain in Configure URLs section.

    When I had “Bucket name in path” selected, the URL was completely wrong for the files. It would show:

    https://s3‑us‑east‑1.amazonaws.com/

    when it needs to be

    https://s3.amazonaws.com/

    Just copy the path where your files are being uploaded and paste it into the “CloudFront or custom domain” selection.

    View post on imgur.com

    Digital Pure

    (@digitalpurenetworks)

    Thanks for the fix…

    Please could you provide your diagnostic information from within the support tab. We’re unable to replicate this issue but we would like to get to the bottom of it.

    Here’s a video of what happens:
    http://screencast.com/t/6Fxhfv4oek

    Hi

    Apologies for this, we have a fix for it on the way. In the short term you can get around the issue for new uploads by selecting another bucket from the list when changing buckets, and then back to your original bucket.

    You can apply this hot fix to the plugin for already uploaded images, in the file /classes/amazon-s3-and-cloudfront.php replace line 1006 with

    if ( isset( $s3object['region'] ) && self::DEFAULT_REGION !== $s3object['region'] ) {

    Let me know how that goes

    Cheers
    Iain

    Hi i have tried aws cloudfront link option with cloudfront link and it did not work for me

    I am using Ubuntu vps/ditial ocean 512mb droplet running easy engine , without cgifast cache ,without w3 total cache, running multiple wordpress websites in a single droplet .

    I will be trying this later

    link cloudfront into w3 total cache (for objects only)alternatively using cloudflare with cloudfront via dns into w3 or s3 offload .

    i am trying your setup for new blogs.
    thank you

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Broken Images’ is closed to new replies.