Support » Networking WordPress » Broken Image Link Multisite when updated to WP 3.8

  • Hi everyone!

    I just updated my WP Multisite to 3.8 and all looked fine for a few hours, until the subsites image linking crashed.

    The head site, http://www.lundagard.se, is working fine. But the sub sites, for example http://www.bytis.lundagard.se or http://www.eng.lundagard.se, have broken image links.

    I can see that the working and not working links have different URL:s, but Im not sure where to go to change the address for the linking.
    Or any other suggestions how to fix the image problem?

    All the best.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    What’s in your .htaccess file?

    Do you mean this one?

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html" [L]
    </IfModule>
    
    # END WPSuperCache
    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Yeah, you’re missing the WP rewrite rules.

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    Thank you for the reply!

    I tried to add the WP rewrite rules, but nothing happend.
    Is there any other code I should try?
    Or can the problem come from any of the Settings in WordPress?

    All the best

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Turn off caching and empty out the /cache folder of any files. ALWAYS empty caches ๐Ÿ™‚

    Thanks again for taking time for this problem!

    I tried to empty out the cache folder, but the problem still exists.
    Can it be something in the settings? I know that I had to change the path link to images in the settings earlier this fall because of a wrong image update.
    Any suggestions?

    All the best!

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    It’s a timthumb error:

    http://eng.lundagard.se/wp-content/themes/lundagard.se-1.1/timthumb.php?src=http://eng.lundagard.se/files/2013/12/Esmail-Ben-Moussa1.jpg&w=165&zc=1&q=80%22

    So … yeah, don’t use timthumb, really. Or in this case, don’t use timthumb that isn’t up to date. Your theme needs to use the newer version of timthumb.

    Thank you!

    I inactivated timthumb for all of my sites, but the problem still exists when Im trying to upload new images.
    Are there more changes to do than just inactivate?

    And do you have any other kind of TimThumb-plugin to recommend?

    All the best.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    View the page source. the images are STILL pointing to TimThumb.

    <article class="post-7258 post type-post status-publish format-standard hentry category-news box col8 stdTopImg " style="position: absolute; left: 0px; top: 1013px;">
                <div class="holder">
    	      <a href="http://eng.lundagard.se/2013/12/12/your-weekly-update-week-50/" rel="bookmark"><img src="http://eng.lundagard.se/wp-content/themes/lundagard.se-1.1/timthumb.php?src=http://eng.lundagard.se/files/2013/12/blog.jpg&w=490&h=250&zc=1&q=80&quot;" class="wp-post-image"></a>
    	<h2><a href="http://eng.lundagard.se/2013/12/12/your-weekly-update-week-50/" rel="bookmark">Your weekly update โ€“ Week 50</a></h2>
    	<p>
              <span class="category">News</span>	  New apartments in Lund, suggestion to lock out late students and a new burglary wave in Lund. This is last week's Swedish news in English.	  <a href="http://eng.lundagard.se/2013/12/12/your-weekly-update-week-50/" class="readmore" rel="bookmark">ยป</a>
    	</p>
          </div>
          <div class="meta"><a href="http://eng.lundagard.se/2013/12/12/your-weekly-update-week-50/#disqus_thread" title="Comment on Your weekly update โ€“ Week 50" data-disqus-identifier="7258 http://eng.lundagard.se/?p=7258">0 Comments</a> - 12 December, 2013</div>      </article>

    Hello,

    After upgrading to 3.8 –

    I have a similar problem where my image links are also not showing the images on my site…

    http://www.feedingkids.tv

    the cpannel I think hosts the site images….

    I also use a plugin ‘total W3 cache’ performance. I have emptied all caches, but that didn’t help.

    I’m not techy but can anyone guide me as to what to do? I’s be eternally grateful!

    lorna

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    I have a similar problem where my image links are also not showing the images on my site…

    Similar but but not the same. Can you please post your own topic? It’s the best way to get assistance for your problem.

    How-To and Troubleshooting

    This topic really doesn’t have much if anything to do with your problem.

    oh okay thanks

    Okay, just erased TimThumb from the server and updated to a new version.
    Still some problems though, and I’ve been trying to find the correct path for hours.
    Any other suggestions?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Don’t use timthumb? Sorry, I know that’s super annoying to hear, but it’s due in part to how the theme is using timthumb. You’ll beed to contact the theme dev directly to address the whole issue.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Broken Image Link Multisite when updated to WP 3.8’ is closed to new replies.