WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Broken Image File Problem

[Resolved] Broken Image File Problem

  • Hoodedmonkey
    Member

    @hoodedmonkey

    Howdy Guys and Gals!

    I recently had a problem with WordPress 2.7 and 2.8 and the solution I found worked with both on a consistent basis so I thought that this problem may be experience by others and here’s a way to fix it.

    Description:
    When I went to upload an image file from my local computer it wouldn’t come up in the preview screen and when inserted into the post it would insert as a box with the ‘broken page’ icon in the middle and no actual picture. When the page was previewed only the name of the file could be viewed and again, no picture.

    Solution:
    Going to Settings-Miscellaneous my uploads folder was set to wp-content automatically, even though it says default is meant to be wp-content/upLoads. I then went into my FTP program and changed the folder security to 777 and went back to WordPress and changed the uploads folder in Settings-Miscellaneous to wp-content/upLoads. I then tried to upload an image and received an error message in red saying that this could not be done. (sorry I can’t remember what the actual error message was, I didn’t copy it at the time I received it) I then went back and changed the upload folder back to wp-content and now my images are inserting into posts perfectly.

    I hope this article may help someone out there.

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Broken Image File Problem’ is closed to new replies.