Support » Fixing WordPress » Broken image (but ok in "Edit Media"

  • Resolved lbleicher


    I run wordpress 3.3.1 in a server I own (running Ubuntu). I didn’t install any plug-ins/themes yet, it’s basically what I get after apt-get and a standard installation.

    When I upload files, they appear as a broken image. That’s also what happens if I try to insert them in the post. What is weird about it is that not only the files are perfectly fine in the media folder, but they can be clearly be correctly read by wordpress itself, because if I go to the media library, click on “edit” and then in the “Edit Image” button, the image actually shows normally. What could be wrong?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Try upgrading your WordPress installation to the latest version, which is 3.5.1.


    I’ve followed those instructions and I’m now running version 3.5.1. The problem is still there, though…

    Just to make sure, you don’t have any plugins running, and you’re testing under the default theme (Twenty Eleven or Twenty Twelve)?

    Have you looked at the options in your Settings dealing with where images are stored?


    Then take a look on your server and make sure that the file structure within your wp-content folder is correct, and that the images are present there (sounds like they are, but double check…)

    If everything looks okay on the server, you might try using the plugin Add From Server ( to reconnect the image to the media library and see if that clears up the broken image. But that would be mainly a bandaid for already existing files, if every new image you upload continues to have this issue.

    It would be a good idea to look at your server logs, to see if anything is showing up there as far as errors in the uploading process.

    Yes, I have tested both Twenty Ten and Twenty Eleven and both give the same problem. I wouldn’t expect it to be theme related, since the problem can be spotted in the media library itself – I have broken images for thumbnails (those in the main Media Library pae) and also when I click on “Edit” for any of the images. The weird thing is that the image actually appears to be perfectly ok when I click on “Edit image”, which means wordpress is actually reading them correctly.

    I have also installed the add-from-server plugin, it could import the jpg from my /upload directory but… same error again – even though the image is just fine when I click on “Edit Image”.

    It’s amazing what can be theme or plugin related, even on the backend, so that’s why testing with the default theme is always step 1 or 2 (the other being to turn off all plugins).

    But anyway.

    This is seriously weird behavior. Does anything show up in your server logs?

    If nothing is there, the next place I would look is at the database. If you have a backup, try restoring from the backup to see if that does anything.

    Beyond that… you’re going to need help from a more technical expert than me.

    I don’t have a backup yet, as I didn’t even managed to add much content to the site: I just made three pages and a blog section with temporary text, and then I immediately noticed that problem. There was never a moment when it actually worked, it happens since my first attempt to add an image…

    After a lot of googling, it seems the issue is solved: I removed the uploads path in Settings->Media and it seems fine now.

    I am having this same issue. I just moved my blog from wordpress hosting to self hosting and everything else moved fine but my images don’t show in the posts and I can’t upload new images.
    I have tried EVERYTHING I know how to try. I have tried different themes, checked the media settings, etc.
    I see several forums discussing this issue but the answers are very technical… check this coding etc… and I have NO IDEA how to do any of that. I just drive the car. I don’t know how to build one, you know?
    I am so lost and so desperate for help and so frustrated that there is no way to contact anyone directly!!!
    My domain is
    Save me, Obi Wan!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Broken image (but ok in "Edit Media"’ is closed to new replies.