[resolved] Broken Homepage, Everything Else Works! (23 posts)

  1. revlimiter
    Posted 7 years ago #

    I have a WordPress driven website http://www.kimstewart.ca
    The pages themselves work fine, however, the blog does not http://www.kimstewart.ca/blog/

    It should be finding this page http://www.kimstewart.ca/blog/page/1/ but it is not...

    I am worried I will need to nuke the site and start over.... Any help is *greatly* appreciated. I am hoping to get this resolved tonight.


  2. MichaelH
    Posted 7 years ago #

    I am worried I will need to nuke the site and start over

    WordPress Backups will help you overcome that worry...

    Couldn't you use one of the techniques described in Giving_WordPress_Its_Own_Directory or How can I have a static front page and posts display on a page called Blog?

  3. revlimiter
    Posted 7 years ago #

    Thanks MichaelH!
    The blog seems to work now when I modify the Reading settings in WP Admin. However, when you click a post name, it does not show /blog/ in front of the URL, example: http://www.kimstewart.ca/hostgator-web-hosting/

    Any ideas how to fix this?

  4. MichaelH
    Posted 7 years ago #

    Seems like you fixed it.

  5. revlimiter
    Posted 7 years ago #

    Thanks, MichaelH.
    The pagination is indeed working again, and all of my blog posts are now inside the /blog/ folder. This is great! Even the search results stay inside /blog/. Exactly what I needed...

    However, the homepage http://www.kimstewart.ca is showing the blog...
    Any ideas how to fix?

  6. MichaelH
    Posted 7 years ago #

  7. revlimiter
    Posted 7 years ago #

    Thanks, MichaelH

    Thanks for the link but I have gone through the WordPress Codex multiple times now, and still can't seem to get it working properly.

    I will try to recap what I have done, exactly:
    In Pages, I have created
    a new page called "My Front Page"
    and a new page called "Blog"

    In General Settings I have set
    WordPress address (URL) to "http://www.kimstewart.ca"
    Blog address (URL) to "http://www.kimstewart.ca/blog/"

    In Reading Settings I have set
    Front page display "A static page (select below)"
    Front page: My Front Page
    Posts page: Blog

    And in permalinks I have set
    Comment settings
    Custom Structure: "/%postname%/"

    This is exactly how my WordPress driven website is running of now on http://www.kimstewart.ca

    I hope this helps get to the problem. I have even created a new WordPress install just to see if mine had a glitch and it is doing the exact same thing (with the default WordPress theme)...
    Thanks for all your help, MichaelH! Hopefully I am 99% of the way there... I just need to figure out this mysterious homepage issue. :)

  8. MichaelH
    Posted 7 years ago #

    So what Template are you using for your Front Page Page. Maybe that Template is also showing your posts...

    If you have no Template assigned to that Page, with the help of the Template Hierarchy article, determine what Template is displaying that Pages.

  9. revlimiter
    Posted 7 years ago #

  10. MichaelH
    Posted 7 years ago #

    Hmm...guess the next thing to do is provide a link to download that theme.

  11. revlimiter
    Posted 7 years ago #

    Thanks MichaelH

    I have uploaded my theme as .zip format onto this site

    (Just click "Download This File" and enter in the characters)

  12. MichaelH
    Posted 7 years ago #

    Too much 'custom' stuff (includes that aren't in the theme directory) there for me to use.

    What happens if you switch to the WordPress Default Theme. Does the problem persist.

  13. revlimiter
    Posted 7 years ago #

    Yes, I have installed it on a brand new URL, with a brand new WP install (2.7) and default theme here:

    And as you can see, pagination is still broken with the "blog" structure

  14. MichaelH
    Posted 7 years ago #

    Maybe the problem is the blog Page name, and WordPress being in the blog subdirectory.

    I setup a test blog with WordPress in a subfolder called wpblog and then create a Page called wpblog and set my Permalink structure to %postname% and my Reading settings to make wpblog be my posts page and I get an error trying to access mydomain.com/wpblog.

  15. revlimiter
    Posted 7 years ago #

    Hmmm, I tried changing my Blog page title to WPblog and then the page slug to wpblog, but still to no avail...

    Oh well...
    Thanks for all of your help anyways, MichaelH!
    It has been very much greatly appreciated!

    I think I have a solution for this, it's not the most ideal way, but it *should* (hopefully) work:

    If I set my Reading settings -> Front Page to show latest posts instead of static pages, that will show my blog on the homepage AND within the /blog directory. Pagination works perfectly - with the /blog added to all of my blog posts (I have currently set it that way on my website, http://www.kimstewart.ca/blog/ if you want to check it out)

    So my solution for the homepage is to just hardcode the homepage in there with a static PHP file, overriting any WordPress pages. This means losing WP backend control over my homepage, but it should still work, right?

    Also, is there a special naming convention for overriting the WP theme homepage? "/wp-content/themes/themename/frontpage.php" or something like that?


  16. MichaelH
    Posted 7 years ago #

    Wish I understood why you are having that problem, but might review the old discussion on Creating_a_Static_Front_Page

  17. Ravenmaster
    Posted 7 years ago #

    i am using the kubrick theme on both of my pages - i have the same plugins, the same set-up and everything seems to be the same but one site will not hold the home page static as i tell it to. and the other one works just fine.


  18. revlimiter
    Posted 7 years ago #

    are they both running WordPress 2.7?

  19. mattg2379
    Posted 7 years ago #


    did you ever get the issue resolved?

    I'm having issues with my blog pagination as you were, and if I change my settings to match yours above (with the permalinks) then I also get my 'home' page showing my blog entries instead of the static page.

    Fixing one problem creates another, and I cant seem to get teh two working together. Any clues/resolutions to the problem would be fantastic.

    Thank you :)

  20. revlimiter
    Posted 7 years ago #

    hey, mattg2379

    I have not yet been able to resolve this issue. It appears as though the link MichaelH provided does not work for WordPress 2.7:

    Any help from the community would be greatly appreciated! Basically, I'm just looking to create a static homepage (index.php or home.php) within my WordPress theme directory, while keeping my blog visible in /blog/ directory. When I try adding "home.php" to my themes folder it also affects my blog located at "/blog".

  21. Ravenmaster
    Posted 7 years ago #

    Both are running 2.7.1. - i have tried everything but nothing will work -

    Here is the problem -

    if i set the home page to home and the blog page to blog - my home page content shows up as the home page and on the blog page.

    If I do not set a static home page - everything displays properly but when you put in the url you get the blog page first and not the home page - the posts are there but it doesnt default to the home page.

    This has been driving me crazy for a couple of weeks now - i Have even installed the home page control plug-in but nothing seems to work -

  22. revlimiter
    Posted 7 years ago #

    Yes - I am having the exact same problem and can't seem to figure it out either... I am beginning to wonder if this is a WP 2.7 glitch...

    Surprised to see very little discussion about this one.
    Any help is greatly appreciated!
    Hopefully this homepage/blog issue will either get cleared up for us in v2.7 or fixed in the next release...


  23. revlimiter
    Posted 7 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.