Support » Plugin: WP Multi Network » Broken for 4.8 ?

  • Hiya,

    I have just upgraded to WordPress 4.8 and can’t get to the admin panel.

    It quits displaying the message

    'Sorry, you are not allowed to access this page.'

    This happens because no user exists, e.g. wp_get_current_user called from get_user_locale, which is triggered by load_plugin_textdomain( ‘wp-multi-network’, returns a zero as ID.

    Solution? Just comment out line 127 of file wpmn-loader.php

    load_plugin_textdomain( 'wp-multi-network', false, dirname( $this->basename ) . '/languages/' );

    Cheers,
    Gabriel

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi Grabriel,

    thanks!!! I love you!
    I can access the wp-admin again of the network!

    This solved the error I was getting:

    Use of undefined constant AUTH_COOKIE – assumed ‘AUTH_COOKIE’ in …/wp-includes/pluggable.php on line 767

    But
    the strange fact is:
    I have a wp multi-site with multi-network
    all the multi-network worked perfectly
    except for 1 which had the error you mentioned.

    ‘Sorry, you are not allowed to access this page.’ … AUTH_COOKIE …

    Your solution solved the problem of this network.

    But surely the problem was not related to 4.8, or at least not to 4.8 alone…

    I cannot find what it is that creates the problem with one network and not in the others…

    Do you have any suggestion?

    thanks

    u.

    • This reply was modified 3 years, 3 months ago by ugo. Reason: typos

    Hi Ugo,

    Glad to hear it was useful, that was the purpose of the comment 🙂

    Sorry, but I have no suggestion.

    See, my solution was for what happened with my install 😉

    Cheers,
    Gabriel

    Gabriel,

    … tried a bit of everything…
    at the end,
    removing and reinstalling my theme (optimizepress)
    seams to have fixed the problem.

    I have removed the commenting out in the wpmn-loader.php

    thanks again,

    U.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Broken for 4.8 ?’ is closed to new replies.