Support » Plugin: Interactive Content – H5P » Broken desktop after updated to 1.14.1

  • The desktop of my site is broken after H5P update.

    Enywhere in the desktop I only see this message:

    The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

    I entered recovery mode and got this message:

    Versión 1.14.1
    This plugin failed to load properly and is paused during recovery mode.

    An error of type E_COMPILE_ERROR was caused in line 49 of the file /var/www/sitios/academiamunicipal/wp-content/plugins/h5p/autoloader.php. Error message: require_once(): Failed opening required ‘/var/www/sitios/academiamunicipal/wp-content/plugins/h5p/h5p-php-library/h5p.classes.php’ (include_path=’.:/usr/share/php’)

    I had to deactivate the plugin. I tried to roll back to previous version but it does not help.

    Has somebody had this issue before? I tried to remove the plugin however I can’t, so it might be due to permission issues.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter marbaque

    (@marbaque)

    I have experienced a similar issue in another site https://multimedia.uned.ac.cr/ecen/

    Is it possible our servers are missing requirements for handling with h5p?

    beckej

    (@beckej)

    Just wanted to add a me-too here.

    Running WordPress Multisite 5.2.2 the dashboard breaks for every site that had H5P enabled.

    Plugin Author thomasmars

    (@thomasmars)

    Hi,
    This error is very general and can be caused by a variety of reasons on your server.
    You can start by checking that the file in the error message, h5p-php-library/h5p.classes.php, exists on your server and that your webserver has permissions to access the file.

    Plugin Author icc0rz

    (@icc0rz)

    @marbaque Yes, it appears PHP is unable to open the file. Could you double-check the file permissions? Also, are you using Git to install/update your plugins?

    @beckej I’m not seeing this on my multisite. Could you check your server’s error_log file for any clues?

    beckej

    (@beckej)

    Thanks for the replies thomasmars and icc0rz

    When this thread didn’t seem to have a response, I went to github.

    https://github.com/h5p/h5p-wordpress-plugin/issues/100

    I believe have solved this issue for myself. I am using a plugin called github updater because my site uses several plugins not in WordPress.org. The github updater breaks for projects that have submodules, and I had to manually reinstall the two folders for the library and editor.

    While this error was technically caused by github updater and not H5P, you might be able to help stop this from happening to future users. 1) if you take the GitHub updater lines of code out of your plugin and stop supporting github updater users will be pushed to the official WordPress repository or 2) you could create a branch on github that has all the dependencies and label it something user friendly.

    Here is a discussion of the issue on github updaters that might give you the information you need.

    https://github.com/afragen/github-updater/issues/349

    Plugin Author icc0rz

    (@icc0rz)

    @beckej Thank you, it looks like we’ll just have to remove the URL for now. It used to be that not specifying the GitHub Branch was enough, but the updater appears to have grown smarter so we’ll just remove it completely until they start respecting submodules. (I don’t see any point in having yet another place(in addition to svn) that we have to clone all of the code.)

    Thread Starter marbaque

    (@marbaque)

    i confirm @beckej ‘s case, since I am using Github Updater plugin too. I removed the H5P folder manually and reinstalled it again. Now it is working.

    • This reply was modified 2 years ago by marbaque.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Broken desktop after updated to 1.14.1’ is closed to new replies.