Support » Plugin: Add Descendants As Submenu Items » Broken Customize page.

  • Definitely Broken Customize page – and no interaction with previous message with the same symptom from 2 years 5 months ago – so you should probably steer clear.
    All plugins deactivated and reverted to default theme to test.

    Fatal error: Uncaught Exception: Supplied nav_menu_item value missing property: status in /home/virtu755/public_html/adventurebods.com/wp-includes/customize/class-wp-customize-nav-menu-item-setting.php:183 Stack trace: #0 /home/virtu755/public_html/adventurebods.com/wp-includes/class-wp-customize-nav-menus.php(692): WP_Customize_Nav_Menu_Item_Setting->__construct(Object(WP_Customize_Manager), 'nav_menu_item[3...', Array) #1 /home/virtu755/public_html/adventurebods.com/wp-includes/class-wp-hook.php(286): WP_Customize_Nav_Menus->customize_register(Object(WP_Customize_Manager)) #2 /home/virtu755/public_html/adventurebods.com/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #3 /home/virtu755/public_html/adventurebods.com/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /home/virtu755/public_html/adventurebods.com/wp-includes/class-wp-customize-manager.php(926): do_action('customize_regis...', Object(WP_Customize_Manager)) #5 /home/virtu755/public_html/adventurebods.com/wp-includes/class-wp-hook in /home/virtu755/public_html/adventurebods.com/wp-includes/customize/class-wp-customize-nav-menu-item-setting.php on line 183

    • This topic was modified 1 year, 2 months ago by  CallMeAndy.
Viewing 4 replies - 1 through 4 (of 4 total)
  • santifri

    (@santifri)

    Hi! same issue here. Is there anybody out there?

    @callmeandy have you found a solution or maybe an alternative?

    Thanks!

    Exactly the same problem. 🙁

    I’m facing the same problem too. Which is a shame since the plugin otherwise works well.

    I found what seems to be a fix for the customize page. Open the file add-descendants-as-submenu-items.php and add the following “$child->status = ‘publish’;” after line 309: “$child->menu_order = $menu_order;”. This should fix the problem.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Broken Customize page.’ is closed to new replies.