Support » Fixing WordPress » Broken Child Theme Worked on Localhost Not on Server

  • Resolved Tony Bianco

    (@tbianco)



    I’m running into a problem that I haven’t had before. I developed on my local host and created a child theme. Everything is worked perfect on my localhost on my mac.

    I do have a style.css in my child theme, but I don’t have an index.php file in my child theme.

    And I did verify that my parent theme was on the server.

    When I uploaded the files and migrated the database from my localhost to my server my child theme is not recognized. I get the following error:

    The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    Name
    Royal Alliance Theme

    Description
    The parent theme is missing. Please install the “Awake” parent theme.

    Here’s my child theme comment:

    /*
    Theme Name: Royal Alliance Theme
    Theme URI: http://www.VeloceMedia.com
    Description: Child theme based on Awake template – DO NOT DELETE AWAKE TEMPLATE!
    Author: Tony Bianco, Veloce Media
    Author URI: http://www.VeloceMedia.com
    Template: Awake
    Version: 1.0
    */

    Here’s my parent template:
    /*
    Theme Name: Awake
    Description: Designed by WebTreats.
    Version: 1.3
    Author: WebTreats
    Author URI: http://themeforest.net/user/Webtreats
    */

    Why is this working on my localhost but not on my server??

Viewing 1 replies (of 1 total)
  • Okay I figured it out myself. If you ever come across this post wondering why it won’t work it’s because the “Template” needs to be case sensitive to the parent folder name not the parent template name. Your localhost on your mac will work fine with the parent name being the template name, but on the server I had to change the template name to the folder name. That did the trick!

Viewing 1 replies (of 1 total)
  • The topic ‘Broken Child Theme Worked on Localhost Not on Server’ is closed to new replies.