Support » Fixing WordPress » Broken Child Theme – Says Parent Missing, but it's NOT

  • Resolved sonora33


    I have this working fine on my local webserver, but on my hosting account at Bluehost, it says the child theme is broken, and that the parent theme is missing. However, it is NOT missing — you can see it here in this screenshot:

    I’ve tried un-installing and re-installing both the parent and the child, but no luck. I can’t find anything helpful in the forums. Please please, someone, help! 😉

    Thank you in advance!

    Betsy (sonora33)

Viewing 6 replies - 1 through 6 (of 6 total)
  • Try removing the parent theme and child theme and re-installing each of them. Something may be missing from one or the other of them which is causing that error.

    Thanks for the suggestion — I tried that several times, but no change. What might be missing? A child theme *should* only need the stylesheet, right? It’s got that.


    The stylesheet in the child theme made reference to the template ‘Agivee’, which WAS installed but apparently it needs to be LOWERCASE. I just changed it in style.css in the childtheme to ‘agivee’ and it is no longer broken.

    Yup- that worked for me too. Same exact problem, and I’m no HostMonster (which I think is the same co as BlueHost).

    Yay! Thank you so much sonora33 — worked for me too.

    Even after fixing the lowercase I still get the same message. I checked and the folder is in the right place, style.css is in there, import reference is correct. I also checked the folder permissions on the server and set public to ‘read’ but still the admin page is telling me the theme is incomplete and to install the parent theme (which obviously is installed and even active).

    HELP! 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Broken Child Theme – Says Parent Missing, but it's NOT’ is closed to new replies.