WordPress.org

Support

Support » Plugins and Hacks » WP eCommerce » [Resolved] Broken checkout

[Resolved] Broken checkout

  • KarlEngstrom

    @karlengstrom

    Been fighting with WPEC 3.8.9.2/3 for about a week. Checkout page disappears if there’s content in the cart & shipping is turned on. I’m not finding any errors thrown or anything. I’ve got it on both staging and production servers and tested with zero other plugins on Twenty Eleven theme. Just plain ol junking out on me. Am I the only one??

    Karl

    http://wordpress.org/extend/plugins/wp-e-commerce/

Viewing 15 replies - 1 through 15 (of 21 total)
  • I have the same problem. When activating the shipping, the checkout page is gone. I don’t find any fix.

    There is discussion in GetShopped forum, but no solution either http://getshopped.org/forums/topic/enabling-shipping-breaks-checkout-as-of-3-8-9/

    KarlEngstrom

    @karlengstrom

    @ATshop- I did end up narrowing it down to items being present in the cart + having shipping turned on. If the cart was empty it would display and tell you it’s empty. I am ShortBuss that is/was posting over at GetShopped.

    I got tired for fighting with WPEC for now & switched my customer’s site to Jigoshop. Some of the options that are included in WPEC I had to pay for in Jigoshop but at least it’s been a stable platform.

    I may return to debugging WPEC after the 3 sites I’m working on are complete but for now I just don’t have time to mess with a buggy plugin.

    If you find anything more about it please post.

    Thanks

    I decided to switch to WooCommerce. So far it’s running good. It seems much stable and has all the functions I need without needing to install extra plugins. 🙂

    KarlEngstrom

    @karlengstrom

    Woo seems to be a good choice. I was testing it before going to Jigo. Woo is a fork of Jigo so they are very similar. Many of the plugins for Jigo are less expensive but Woo’s may be more comprehensive, I’ve no way to know until I actually go down that road or someone reports on a side by side comparison.

    I’m hoping WPEC works things out for the sake of current & future users. It seems as though they may be biting off too much in expanding the plugin and not cleaning up the code already in place. For one I saw way too much intrusion on existing WP tables (inserting new fields) where joins from new tables would probably have worked cleaner.

    Wishing you well with Woo!!

    Thanks
    Karl

    Andrew Bartel

    @andrew-bartel

    Did you try upgrading it to 3.9?

    KarlEngstrom

    @karlengstrom

    Last version I worked with was 3.8.9.3. I’ll be testing more with WPEC on the staging server when I have time. Has the checkout issue been addressed? I don’t see available?

    Andrew Bartel

    @andrew-bartel

    I use it on one production site and I’ve never experienced the issue, but the theme I’m using was originally built specifically for wpec (splashing pixels) and I’ve basically overwritten the whole thing in the child.

    KarlEngstrom

    @karlengstrom

    Could you point me to a link for 3.9?

    Andrew Bartel

    @andrew-bartel

    Sorry space cadet move on my part, checked my version, it’s the same as yours, there is no 3.9. Have you tried it on other themes (I agree that it should work on 2011)?

    KarlEngstrom

    @karlengstrom

    I believe I tried it on 2010 as well, I was taking notes at the time. I’ll be doing a fresh install of WP, WP database & WPEC next week, probably. I’ll pop back in & update my findings.

    Thanks
    K

    Andrew Bartel

    @andrew-bartel

    I’m starting a huge wpec project from the ground up tomorrow, keep in touch.

    vassil510

    @vassil510

    Please add me to the list of people experiencing the Blank-Checkout-Page-When-Shipping-Is-Enabled. Using WP e-Commerce 3.8.9.3, with the UPS rate calculator turned on and configured. When the UPS info is missing, the page is not blank but then the calculator doesn’t work. As soon as I fill out all the required information, the page turns blank again. My items do have their weights and dimensions configured… I’ve been trying to figure this out for hours now; deactivated all other plugins, changed themes, reinstalled the plugin and reentered all the information, to no avail! Does anyone have a solution? I’ve spent days setting up and styling this – is it salvageable or do I have to start over from scratch, with a different plugin?

    KarlEngstrom

    @karlengstrom

    Welcome to the WPEC Broken Checkout Group vassil510, LOL…

    Just keep checking back here. We can keep this going as long as we keep posting to it. They definitely have some kind of issue but it’s not being addressed as far as I know.

    There’s a thread or two over at getshopped about this but most all the reactions are “works fine here, you must be doing something wrong” type of thing.

    vassil510

    @vassil510

    Thanks Karl, I’m dying to see how this ends. Just did a fresh install of WP and WPEC on a new server, and the moment I activated the UPS calculator, the same exact thing happened: the header and top nav loaded, up to the entry-header, and then nothing. Must get some sleep now: tomorrow will be a long day, since I’ll most likely be getting rid of this piece of you-know-what and replacing it with a plugin that actually works…

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Broken checkout’ is closed to new replies.
Skip to toolbar