WordPress.org

Forums

Easy Digital Downloads
[resolved] Broken buttons (15 posts)

  1. lucyh
    Member
    Posted 2 years ago #

    Hi,

    I have loved using this plugin but recently the buttons for buying and proceeding to checkout appear to be broken. All that displays is a box of the specified colour with no text inside.

    These were working fine until about 2-3 weeks ago - so I guess this could have followed an upgrade. I am using v 1.3.2.1

    I've checked to make sure the right text is still included in the Complete Purchase and Add to Cart fields in 'Misc' and it is there - but wont display unless I remove buttons and activate text instead - which doesn't look as good. I have disabled styles for time being - but the standard grey submit button isn't quite as compelling as my blue 'Buy Now' button was.

    I've also noticed my purchase and download log is suddenly empty even though higher up it registers a number of sales.

    Sorry if I am overlooking something obvious. I am not a power user!

    Thanks

    http://wordpress.org/extend/plugins/easy-digital-downloads/

  2. Pippin Williamson
    Pippin's Plugins and Plugin Reviewer
    Plugin Author

    Posted 2 years ago #

    Can you give me a live URL so that I can see the buttons?

  3. lucyh
    Member
    Posted 2 years ago #

  4. Pippin Williamson
    Pippin's Plugins and Plugin Reviewer
    Plugin Author

    Posted 2 years ago #

    I see the problem. It's caused by CSS in your theme. Add this to your theme's style.css file:

    .edd-submit { text-indent: 0!important; }

  5. lucyh
    Member
    Posted 2 years ago #

    Thanks for looking into this for me. I have added the code at the end of the theme style CSS but it doesn't seem to have changed anything - the 'buy now' buttons still come up blank - although checkout seems to work for some reason... (I think it did before too) Possibly just a bug special to me.

    regards,

    Lucy

  6. Pippin Williamson
    Pippin's Plugins and Plugin Reviewer
    Plugin Author

    Posted 2 years ago #

    Both buttons seem to be working fine for me now, though it appears that you have added additional custom CSS, so that could be it.

  7. lucyh
    Member
    Posted 2 years ago #

    That is because I removed styles and reverted back to default grey submit button. These have always worked fine. But if I untick the box again - the 'buy now' text no longer shows up on the blue buttons.

    cheers

  8. Pippin Williamson
    Pippin's Plugins and Plugin Reviewer
    Plugin Author

    Posted 2 years ago #

    I'll need to see it with the default buttons again in order to see what is happening.

  9. lucyh
    Member
    Posted 2 years ago #

  10. Pippin Williamson
    Pippin's Plugins and Plugin Reviewer
    Plugin Author

    Posted 2 years ago #

    Ok the CSS I gave you before will definitely fix it.

    Are you sure you put it in the right file? Does your theme have a "Custom CSS" option?

  11. lucyh
    Member
    Posted 2 years ago #

    Hi - no not sure that I put it in the right file. There only seemed one place to go - Under the 'appearance' menu on the left hand side of my dashboard there is an option called 'editor'. I opened that up and found this:

    Nature_wdl: Stylesheet (style.css)

    I added the code at the very bottom - as instructed by my webhost and the theme designer. So this is how it looks at the bottom of the theme editor:

    .edd-submit {
    text-indent: 0!important;
    }

    /* End ACCESSITES CSS */

    (PS Not sure what the /* End Accessites CSS */ code means but I tried it above and below it and neither seemed to work.)

    Sorry if that was wrong - I am not a power WordPress user.

  12. Pippin Williamson
    Pippin's Plugins and Plugin Reviewer
    Plugin Author

    Posted 2 years ago #

    Is the code still there or did you remove it?

  13. lucyh
    Member
    Posted 2 years ago #

    It's still in there.

  14. lucyh
    Member
    Posted 2 years ago #

    I just double checked - and pasted you code in again over the top of what was there and the buttons now seem to be working beautifully - so perhaps I introduced an error or space somehow - if so I apologise! (I'm a newbie at html)

    So happy it is fixed now.

    many thanks for your help.

  15. Pippin Williamson
    Pippin's Plugins and Plugin Reviewer
    Plugin Author

    Posted 2 years ago #

    Great!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Easy Digital Downloads
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic