Support » Plugin: Multiple Featured Images » Broken after update

  • Hi
    Updated a site to WP 4.7.2 and updated this plugin at the same time. The site went down and realised the plugin was causing the problem (renamed via FTP).

    In the admin when I try to activate it I get the error:

    Parse error: syntax error, unexpected T_STRING in /hsphere/local/home/thehub-edinburgh/thehub-edinburgh.com/wp-content/plugins/multiple-featured-imagesx/multiple-featured-images.php on line 58

    Any idea what the problem is?

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’m also getting this. Did you have any luck with a solution?

    Hi,

    I just registered to come here and let you know that I encountered the same issue and was able to resolve it by setting the server’s PHP version to 5.4. After doing some research, it appears that the method which this plugin uses to register the function is only supported by PHP 5.3 and later.

    If your server runs cPanel, you should be able to change the PHP version (if you server supports it) by looking for the “PHP Configuration” page in cPanel.

    Good luck!

    Trishah

    (@trishahdee)

    Thank you @harley for the PHP version information! This is the second multiple featured image plugin that gave me an issue and it was driving me crazy trying to find the “conflict”. So thank you!

    NOTE: I also tried the Dynamic Featured Image PRO version is having the same problem but not their FREE version.

    Ankit Pokhrel

    (@ankitpokhrel)

    Dynamic Featured Image PRO requires PHP 5.4+. Upgrade your PHP, that should solve the issue.

    Trishah

    (@trishahdee)

    Hello Ankit,

    My cPanel says “You’re currently configured to use PHP 5.6”.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Broken after update’ is closed to new replies.