Support » Plugin: Top Quark Architecture » broken admin pages.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author topquarky

    (@topquarky)

    Hi @victomeyezr,

    I saw the same post for the poMMo plugin and responded there.

    I’ve not seen the invalid content type error before. I’d like to try and resolve whatever’s happening for you (it works fine on plenty of sites, trust me).

    If you need to send a screen shot, you can send it to t _at_ topquark _dot_ com.

    Thanks
    Top Quark

    Hi – i tried activating v2.0.13 and had some issues that might be related … see two error messages below … cordially, chuck scott

    ps – not sure this matters but i tried to install on Multisite Network sub domain via WP 3.2.1

    ====================
    error message 01 ->
    ====================
    The plugin generated 692 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    ====================
    error message 02 ->
    ====================
    note i put in mydomain instead of direct account …

    Warning: include_once(/home/mydomain/public_html/wp-content/plugins/topquark/lib/../../../../wp-config.php) [function.include-once]: failed to open stream: No such file or directory in /home/mydomain/public_html/wp-content/plugins/topquark/lib/env.php on line 11

    Warning: include_once() [function.include]: Failed opening ‘/home/mydomain/public_html/wp-content/plugins/topquark/lib/../../../../wp-config.php’ for inclusion (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/mydomain/public_html/wp-content/plugins/topquark/lib/env.php on line 11

    Plugin Author topquarky

    (@topquarky)

    Hi Chuck,

    Does the file /home/mydomain/public_html/wp-config.php exist in your setup? That’s the file it’s trying to load.

    Those two issues are definitely related. The second causes the first (how’s that for causality!).

    If that file does indeed exist, then we’ll need to figure out why it doesn’t get included. If it doesn’t exist there, then I need to learn about your WP setup, as I thought that file being there was a certainty.

    Cheers
    Trevor

    hey trevor – thanks for super fast response … interesting … my wp-config.php files are normally moved up north of www root thus to help with security as that is what i read and saw in other posts about one of the ways to help prevent hacks … hence my file path for this site is -> /home/mydomain/wp-config.php … thanks in advance for help and pointers … cordially, chuck scott

    Plugin Author topquarky

    (@topquarky)

    Hmmmm…

    I haven’t seen that setup before. What is your ABSPATH constant set to? /home/mydomain/ or /home/mydomain/public_html/?

    You could change the offending line in env.php:

    include_once(dirname(__FILE__).'/../../../../wp-config.php');

    to…

    $path_to_config = apply_filters('topquark_path_to_wp_config',ABSPATH.'wp-config.php');
    	include_once($path_to_config);

    Then, if you need to you can use a filter to properly set the path. I’ve made that change in the plugin and will release it in a future update, but I’d like to make sure you’re up and running (maybe there will be other issues with your setup).

    Cheers
    Trevor

    i’m not sure about ABSPATH constant but did as you suggested – e.g., change the file “env.php” from the include_once to the variable of $path_to_config = … yet to no avail … see data points below …

    ====================
    error message 03 ->
    ====================
    The plugin generated 604 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    ====================
    error message 04 ->
    ====================

    Warning: include_once(/home/mydomain/public_html/wp-config.php) [function.include-once]: failed to open stream: No such file or directory in /home/mydomain/public_html/wp-content/plugins/topquark/lib/env.php on line 15

    Warning: include_once() [function.include]: Failed opening ‘/home/mydomain/public_html/wp-config.php’ for inclusion (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/mydomain/public_html/wp-content/plugins/topquark/lib/env.php on line 15

    Plugin Author topquarky

    (@topquarky)

    ABSPATH is a constant that gets set to the directory that wp-config.php “normally” is in. Your case is different obviously.

    So, I’d recommend keeping that code in there, but adding a filter to another plugin (some plugin that is network activated, maybe you have to make a new one) and put the following in it:

    add_filter('topquark_path_to_wp_config','my_path_to_wp_config');
    function my_path_to_wp_config($path){
        $path = '/home/mydomain/wp-config.php';
        return $path;
    }

    That should then tell Top Quark where to find your wp-config.php file.

    hey trevor – just a quick follow up … i tried a number of things including putting the filter in the mu-plugin folder for network activation but did not help … so i moved the wp-config.php to public www root and went back to default plugin files and that worked which gave me ability to take plugin for a spin … accordingly, big thank you for your assitance with all this … best wishes for Happy Holiday Season and best of ongoing success in 2012 and beyond! cheers – chuck scott

    Plugin Author topquarky

    (@topquarky)

    Hi Chuck,

    Glad you got it working. Best of the season to you!

    Cheers
    Trevor

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘broken admin pages.’ is closed to new replies.