WordPress.org

Forums

Timeline
Broke theme, error message (5 posts)

  1. vegastriguy
    Member
    Posted 12 months ago #

    Every date generates an error message if there is no video or image attached to the year and then it broke my theme for the actual post.

  2. DotsquaresLtd
    Member
    Plugin Author

    Posted 12 months ago #

    Hello vegastriguy,

    Thanks for showing your interest and downloading our plugin. We are always here to help you for any kind of issue you face.
    Could you please explain what information you are using for the event? Also could you please share the screen capture with the error message so that we can check accordingly.
    We have checked at our end by not attaching image or video with event. But could not replicate the error.
    Due to security reason, could you please email us your website url, website admin details and FTP details at : support.extensions@dotsquares.com
    You can change these details once we corrected the issue.

    Kindest Regards,
    DS Team.

  3. JCKnoell
    Member
    Posted 11 months ago #

    http://www.bebraveinfertilityjourney.com/wp-content/uploads/2014/05/Capture.jpg

    This is what he means. It says "no image" or "no video" if there isn't one there...
    http://www.bebraveinfertilityjourney.com/sample-page/timeline/

    Can we instead put a thumbnail there if there IS a pic? Or some sort of callout so they know there's one there?

    And then remove the error if there isnt... :)

  4. JCKnoell
    Member
    Posted 11 months ago #

    Here's my fix, which worked. Go to "editor" under the plugins tabs on your admin panel. Find the timeline plugin and search for the following code:
    if($imgSrc!= '')

    Underneath there, you'll see the if/then statements which say if there is a video, display "event video", else display "No video".

    Just either delete the "no video" text or put comments around it so it's not read. E.g. the following:

    if($imgSrc!= '') {
    								$timeline_text .= '<li>
    										<a href="'.$imgSrc.'" rel="prettyPhoto">
    											Event Image
    										</a>
    									</li>';
    							} else {
    								$timeline_text .= '<li><!--No Image--></li>';
    
    							}
    							if($video['0']!= '') {
    								$timeline_text .= '	<li>
    										<a href="'.$video['0'].'" rel="prettyPhoto">
    											Event Video
    										</a>
    									</li>';
    							}else {
    								$timeline_text .= '<li><!--No Video--></li>';
  5. JCKnoell
    Member
    Posted 11 months ago #

    I'd still very much appreciate some sort of thumbnail though for when there is a vid/pic... Can we do that instead? :)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.