WordPress.org

Ready to get started?Download WordPress

Forums

Broke site due to editing wp-config.php, please help. (4 posts)

  1. Bravo2Red
    Member
    Posted 6 years ago #

    Hello,

    I was editing my website, trying to move from wp-cache to wp-super-cache (the plugins) and I' messed up, I removed the line "define(’WP_CACHE’, true)" I then uploaded the file and my website (http://www.trulyrandom.net) turned into the way it is now. I've tried putting the line back in but it does'nt seem to be working.

    so I'm turning to you the great support people to ask if you could help me.

    My current wp-config.php is as follows:

    <?php // ** MySQL settings ** //
    define('DB_NAME', '[redacted]');    // The name of the database
    define('DB_USER', '[redacted]');     // Your MySQL username
    define('DB_PASSWORD', '[redacted]'); // ...and password
    define('DB_HOST', 'localhost');    // 99% chance you won't need to change this value define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');  // Change each KEY to a different unique phrase.  You won't have to remember the phrases later,
    // so make them long and complicated.  You can visit http://api.wordpress.org/secret-key/1.1/
    // to get keys generated for you, or just make something up.  Each key should have a different phrase. define('AUTH_KEY', 'f7sXx[2wbB@LBwlxS{A56y>+cCIfn5F[d[nsXz iq\\Ms}?(;_a#ypoR5\'3w<G5>FL~1X'); // Change this to a unique phrase. define('SECURE_AUTH_KEY', '-\"r642fed3E1d>}MdGFlh@tR!QPU%/!S_6;CjO0}^>6TcCIfn5F[d[ns+ <?)3 U#*X;'); // Change this to a unique phrase. define('LOGGED_IN_KEY', 'Q^l\"6-pLcCIfn5F[d[ns\zkw>OG<U$%u0:9H:Jl)+d$~jIBTt&CPL[Dp<KY4zL3y'); // Change this to a unique phrase.  // You can have multiple installations in one database if you give each a unique prefix $table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!  // Change this to localize WordPress.  A corresponding MO file for the // chosen language must be installed to wp-content/languages. // For example, install de.mo to wp-content/languages and set WPLANG to 'de' // to enable German language support. define ('WPLANG', '');  /* That's all, stop editing! Happy blogging. */  if ( !defined('ABSPATH') ) 	define('ABSPATH', dirname(__FILE__) . '/'); require_once(ABSPATH . 'wp-settings.php'); ?>

    Please help,
    Daniel Johnson

    :)

  2. ClaytonJames
    Member
    Posted 6 years ago #

    Hi, Daniel.

    I'm not sure what is going on with with your config file, but it appears that you may have actually just posted your website url, your database name, database user name, database password, and auth keys. Unless these pieces of info are fake (some of it looks pretty real to me), for the sake of this post, you need to give some consideration to taking care of that situation.

    Here is the error that is present when trying to access your home page, if it is any help.

    Fatal error: Call to undefined function wp() in /home/truljoh9/public_html/wp-blog-header.php on line 14

  3. Bravo2Red
    Member
    Posted 6 years ago #

    I don't seem to be able to change something I've already posted. :(

  4. ClaytonJames
    Member
    Posted 6 years ago #

    I put a "mod look" tag on it. Perhaps one of the moderators would be kind enough to delete the code you posted.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags