Support » Plugin: Autoptimize » Broke My Site

  • Resolved Anirban Roy

    (@heyanirban)


    Hi!
    I have been using this plugin for a long time and never ever thought that this was the culprit.

    My WordPress site running the Newspaper theme is showing random parts broken. I was told that I am using an incompatible plugin. So i started deactivating my plugins one by one to find out which one was the culprit.

    As soon as I deactivated the Autooptimize plugin, my whole site broke at once! But again after reactivating it, site was fixed again but only some random parts broken.

    I have also seen another person posting a similar thread where he faced the same problem that his site was broken on deactivating this plugin.

    The problem that my site is facing with this plugin currently is that, when any article is opened on mobile phone and scrolled down till the when and the a new article starts to load using the infinite load feature, parts of the new article appears broken.

    And when I deactivate this plugin, my site breaks completely.

    Kindly tell me how to safely deactivate this plugin so that my site doesn’t break down.
    Thanks!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 32 total)
  • Thread Starter Anirban Roy

    (@heyanirban)

    I’m keeping the AO plugin deactivated for sometime so that you can see for yourself how terrible the site is looking

    Thread Starter Anirban Roy

    (@heyanirban)

    Well, I’m reactivating the AO plugin for now as it is hampering the user activity on my site now.

    here you may see how my site is looking on desktop without the AO plugin: https://imgur.com/a/OYnmIqZ

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    can you clear your page cache(s)?

    Thread Starter Anirban Roy

    (@heyanirban)

    i have deleted all the cache.
    1. DELETED ALL CACHE FROM WP SUPER CACHE.
    2. TURNED ON CLOUDFLARE DEVELOPMENT MODE.
    3. TURNED OF HOSTING CACHE.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, seems to work for me now;

    Thread Starter Anirban Roy

    (@heyanirban)

    ohh i see now that clearing the cache after deleting the pwa files has fixed the infinite scroll issue

    Thread Starter Anirban Roy

    (@heyanirban)

    it works because AO is on

    Thread Starter Anirban Roy

    (@heyanirban)

    IF I TURN AO OFF IT WON’T WORK. I’M TURNING OFF AO AGAIN. SEE THEN.

    Thread Starter Anirban Roy

    (@heyanirban)

    please check now

    Thread Starter Anirban Roy

    (@heyanirban)

    well i don’t know what’s going on!! IT was broken just a few seconds ago. HOW DID IT GET FIXED?!

    Thread Starter Anirban Roy

    (@heyanirban)

    okay, so as it works correctly now, what would you recommend me to do now? should i enable AO and the other deactivated plugins again?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, I don’t know what your original goal of disabling plugins was so hard to say, but if you re-enable to it one by one, clearing the page cache(s) and testing between each one πŸ™‚

    Thread Starter Anirban Roy

    (@heyanirban)

    okay, thank you so much for your amazing support! really appreciate it! You’re much better than the paid customer services. I will soon buy the premium version of your plugin. Also, may i know, whom am I talking to? is it Frank?

    Also, could you please recommend me the best caching setting for my site to prevent such errors?

    Cloudflare Caching Level: You can chose between Basic, Simple and Aggressive mode. The basic setting will cache most static resources (i.e., CSS, images, and JavaScript). The aggressive setting will cache all static resources, including ones with a query string. The simple setting will ignore the query string when delivering a cached resource.

    thanks!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    yeah, I’m Frank πŸ™‚

    re. (cloudflare) caching setting; I’d go with “simple”, but I’m not a cloudflare expert (don’t use it myself).

    Thread Starter Anirban Roy

    (@heyanirban)

    thanks a lot, again, Frank!

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘Broke My Site’ is closed to new replies.