Support » Plugin: Autoptimize » Broke My Site

  • Resolved Anirban Roy

    (@heyanirban)


    Hi!
    I have been using this plugin for a long time and never ever thought that this was the culprit.

    My WordPress site running the Newspaper theme is showing random parts broken. I was told that I am using an incompatible plugin. So i started deactivating my plugins one by one to find out which one was the culprit.

    As soon as I deactivated the Autooptimize plugin, my whole site broke at once! But again after reactivating it, site was fixed again but only some random parts broken.

    I have also seen another person posting a similar thread where he faced the same problem that his site was broken on deactivating this plugin.

    The problem that my site is facing with this plugin currently is that, when any article is opened on mobile phone and scrolled down till the when and the a new article starts to load using the infinite load feature, parts of the new article appears broken.

    And when I deactivate this plugin, my site breaks completely.

    Kindly tell me how to safely deactivate this plugin so that my site doesn’t break down.
    Thanks!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 32 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Kindly tell me how to safely deactivate this plugin so that my site doesn’t break down.

    Clear any page cache you might have and things should be OK.

    Thread Starter Anirban Roy

    (@heyanirban)

    I have tried deactivating all the cache from autooptimize before deactivating it, from Wp super cache after deactivating it and also from cloudflare but still the site was broken. Then i had to reactivate autooptimize again and the site was fixed again. So as you see, clearing cache is not fixing the problem.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, some feedback:
    * I see x-proxy-cache mentioned in the HTTP response headers, so you likely have yet another caching layer, probably at your hoster.
    * The page is broken when AO is not active due to resources not existing (404);

    As AO is not active at that point (due to the ?ao_noptimize=1 part of the URL), the problem is elsewhere.

    * You have some PWA plugin active, I *think* it is interfering with the infinite scroll

    I would start with disabling the PWA first and foremost?

    Thread Starter Anirban Roy

    (@heyanirban)

    So, does it mean that Autooptimize is doing no harm to my site? (i love this plugin and will be very happy to know that).

    It’s not actually a PWA plugin. I made the PWA by myself using Microsoft’s PWA builder website and installed it manually. Okay, i will try disabling it and see.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    indeed, when AO is not active, you see your site as if AO never was there; it does not make any changes to other plugins/ your theme.

    Thread Starter Anirban Roy

    (@heyanirban)

    Well, then why does my site look perfect ( see the homepage) when AO is activated. But breaks down completely once it is deactivated?? If you can i can send you a screenshot of it

    Thread Starter Anirban Roy

    (@heyanirban)

    I will try turning off the host site caching but i will have to check though.. whether they actually cache anything or not.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Looked at the HTML source of an un-optimized page again and I see that on the front-end you’re not using wp-content/plugins, wp-content/themes or wp-content/uploads, but rather a trb-plugin, trb-tdivcom and trb-uploads which I guess is rewritten at webserver level to the correct directories.

    The issue is; you also have
    https://www.techrbun.com/trb-template/trb-css-style
    https://www.techrbun.com/trb-clib/assets/js/js_posts_autoload.min.js
    https://www.techrbun.com/trb-clib/assets/js/js_files_for_front.min.js

    and those (for reasons I don’t know) are not found, there might be others as well.

    So the question is; what is doing those (weird) rewrites, what logic is behind it and why are some of those broken?

    Thread Starter Anirban Roy

    (@heyanirban)

    A plugin called Wp-Hide and security enhancer is making those changes, but those are not server level changes.

    Could you please explain how are you seeing the unoptimised versions? Because the AO plugin is active on my site, so you shouldn’t be able to see the unoptimized version. If you want, i can deactivate the plugin temporarily and then you can see how the site breaks down completely.

    And the reason for which some files are unknown, is even unknown to me.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Could you please explain how are you seeing the unoptimised versions? Because the AO plugin is active on my site, so you shouldn’t be able to see the unoptimized version.

    by adding ?ao_noptimize=1 to the URL 🙂

    If you want, i can deactivate the plugin temporarily and then you can see how the site breaks down completely.

    no need, I can see it 🙂

    And the reason for which some files are unknown, is even unknown to me.

    I’d say; disable hide my wp for a second and see if things improve? 🙂

    Thread Starter Anirban Roy

    (@heyanirban)

    Yes, i will try everything that you recommended now. And will let you know if things improved.

    1. Check host cache
    2. Delete pwa
    3. Delete wp hide

    Thread Starter Anirban Roy

    (@heyanirban)

    Also, i checked by using the ?ao_nooptimize=1 to the url but, it doesn’t correctly demonstrate the issue that i am facing after deactivating the plugin. Please wait i will send the screenshot soon

    Thread Starter Anirban Roy

    (@heyanirban)

    THIS IS HOW MY SITE LOOKS LIKE ON DEACTIVATING THE AO PLUGIN: https://imgur.com/a/uRmTSnt

    Thread Starter Anirban Roy

    (@heyanirban)

    Also, i have deleted the pwa but that doesn’t fix the infinite scroll issue.
    please check the pictures : https://imgur.com/a/yCcGCxa

    Thread Starter Anirban Roy

    (@heyanirban)

    also deactivated wp-hide but still no good

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘Broke My Site’ is closed to new replies.