WordPress.org

Forums

[resolved] Broke my admin trying to transfer plugin.... Help. (5 posts)

  1. J. Brown
    Member
    Posted 3 years ago #

    Hey-

    I redid an old static html site with wordpress and I tried to grab my subscribe-to-coments plugin from another site and put into onto this new one. I just grabbed the folder via ftp and threw into the new plugins folder. When I tried to activate it something broke. I deleted the plugin file but now .....

    .... the site is working. I can log in to my admin and go to settings, and several items along my admin bar. I can edit particular pages or posts by hitting the "edit page" in the upper admin bar while viewing the page logged in. But I cannot get to the Pages or Plugins or Posts or Widgets pages, all I get is this error:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home/abhyasay/public_html/wp-admin/includes/menu.php on line 126

    Everything was working fine before I monkeyed with the plugin. I'm on a steep learning curve with WordPress and am at a loss as to how best to proceed.

    If anyone could help me out I'd be much obliged.
    Thanks.

    site: http://www.abhyasayogacenter.com

  2. govpatel
    Member
    Posted 3 years ago #

    Seems as you need increase your memory and you can follow this steps

  3. J. Brown
    Member
    Posted 3 years ago #

    I sure thank you for taking a moment. I tried adding the code to my config file and .htacess file but I don't seem to have access to my php.ini file. I also tried activating the plugin that was linked to and was even able to get it uploaded as I got to the "Add new" plugin page through the top nav but when I went to activate it, I get the same error. Seems strange though. I have another site that has just as many plugins, more, and never ran into this error. I have reached out to my host to see whats can be done. if you should have any further suggestions that would be beyond helpful.

    Cheers.

  4. govpatel
    Member
    Posted 3 years ago #

    You will have just wait for your host to increase the memory limit as most hot do restrict the setting I had the same problem and my host increased my limit.

  5. J. Brown
    Member
    Posted 3 years ago #

    Just in case someone comes across this before they find the other threads, I was able to solve this on my own without my hosting providers assistance. Simply add a file named "php.ini" to your wordpress admin folder with the following in it:

    memory_limit = 128M ;

    All good. Apparently, hosting providers often have defaults that can be overridden. Supposedly, there are some providers that don't allow you to override but most do.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.