Support » Plugin: Broadcast » Broadcasting duplicates of custom post

  • Resolved vtoshmorelli

    (@vtoshmorelli)


    I’m using Broadcast with WPML and ACF and testing by pushing a custom post type of Products to one test site with only English and a second test site that has 10 languages active.

    When I broadcast one product to both sites, I get two copies of the product in both sites.

    When I then broadcast one of the translations of the product to the multilanguage site, it also sends two copies of the product but only one seems connected to it English version.

    WP 5.5.5, Broadcast with Premium Pack, WPML 4.2.1, ACF Pro 5.7.13

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author edward_plainview

    (@edward_plainview)

    Interesting. I recently had someone else contact me with a similar dupe problem, but he was using the latest beta version of ACF. A previous beta version did not cause dupes.

    A broadcast debug dump could be useful, but first try disabling ACF and broadcasting to see if ACF is involved in this mess.

    I did some basic test posts with ACF still turned on. When I broadcast to the single language site it sent one copy. When I broadcast to the multilanguage site, it sent two copies.

    Turned off ACF and created a second test post and it only sent one copy to each site.

    Plugin Author edward_plainview

    (@edward_plainview)

    So ACF is the culprit. It hasn’t done this before, eh? Could you enable Broadcast debug mode, broadcast the post to the ML site and then send me the debug text?

    Emailed you the file.

    Plugin Author edward_plainview

    (@edward_plainview)

    Got it and read through it. Saw absolutely nothing weird other than a broadcast being called twice within milliseconds.

    2019-03-28 18:32:25.1517 ThreeWP_Broadcast: System info:
    2019-03-28 18:32:25.1779 ThreeWP_Broadcast: System info:

    There appears to be an issue with ACF already:

    https://github.com/AdvancedCustomFields/acf/issues/161

    Great… I intentionally avoided updating ACF because one of my test sites updated to the 5.8 beta and was causing issues but I needed to get on the same version my developer was using.

    Maybe I can roll back to a previous point update.

    Just to update. ACF has a temporary solution that worked for me on that same issue at:

    https://github.com/AdvancedCustomFields/acf/issues/161

    Had to modify a couple lines of code in the plugin but it worked.

    Thanks for your help!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.