Support » Plugin: Breeze - WordPress Cache Plugin » Breeze .htaccess code breaks site

  • A site had Breeze installed and it completely broke with a 500 Internal Error. Removing the code that Breeze had added to .htaccess recovered the site.

    What is the cause?

    WP 5.6 Salient Theme. PHP 7.4 Apache server

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter 123host

    (@123host)

    Update on this: The line SetEnv BREEZE_BROWSER_CACHE_ON 1 in .htaccess is what is causing it. If I comment out that line there is no problem.

    Plugin Author adeelkhan

    (@adeelkhan)

    This issue arises as a result of a conflict with multisite configuration. Can you confirm that there is no other htaccess rule about browser cache settings?

    Thread Starter 123host

    (@123host)

    Here’s the entire .htaccess

    
    # cat .htaccess
    
    # BEGIN WordPress
    # The directives (lines) between "BEGIN WordPress" and "END WordPress" are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # php -- BEGIN cPanel-generated handler, do not edit
    # Set the “ea-php74” package as the default “PHP” programming language.
    <IfModule mime_module>
      AddHandler application/x-httpd-ea-php74 .php .php7 .phtml
    </IfModule>
    # php -- END cPanel-generated handler, do not edit
    
    sclosson

    (@sclosson)

    I’m having the same problem here with viamonteliving.org. The .org site is parked, and added as an addon under viamonteliving.com (which has been set to redirect to viamonteliving.org). I did not setup the domains as this was done way before I touched the site. I’m not trying to go down a path of changing the DNS to fit for this plugin either. I’m just trying to get the site cached properly using this plugin (is possible). The .htaccess for the site is as follows:

    # BEGIN WordPress
    # The directives (lines) between "BEGIN WordPress" and "END WordPress" are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # php -- BEGIN cPanel-generated handler, do not edit
    # Set the “ea-php71” package as the default “PHP” programming language.
    <IfModule mime_module>
      AddHandler application/x-httpd-ea-php71 .php .php7 .phtml
    </IfModule>
    # php -- END cPanel-generated handler, do not edit

    I removed all of the code that the Breeze activation added and also deleted this plugin completely. I am seeing a cache directory in wp-content also, not sure if this plugin added that or not.

    It would be great if I could get this plugin working properly with the current DNS configuration. Not even sure the DNS configuration is the problem here, but it appears so as you mentioned it to previous questions related to this 500 Error.

    Do you know if it’s possible to fix this manually or something so that I can use this plugin with the current setup of the domains perhaps?

    • This reply was modified 8 months ago by sclosson.
    • This reply was modified 8 months ago by sclosson.
    • This reply was modified 8 months ago by sclosson.
    Thread Starter 123host

    (@123host)

    There seems to be no interest in resolving this.

    sclosson

    (@sclosson)

    Unfortunately.

    Plugin Author adeelkhan

    (@adeelkhan)

    Could you please confirm that you have a redirection issue while enabling the Browser Compression rule from Breeze? Also, have you seen the cache folder in your wp-content folder after the deactivation of Breeze?

    I am experiencing a similar issue, made far worse by the fact that my .htaccess file now has *duplicated* sections, whole chunks of duplicated code that I suspect was duplicated by Breeze itself. We already had gzip enabled, far-future expiry, mime types all configured and Breeze has gone and put the definitions in again. Doesn’t it even bother to check the contents of htaccess first??

    My confidence in Breeze now (and Cloudways, who seem unable to fix this problem) is at rock-bottom. The only solution is to deactivate and delete Breeze and consequently take ourselves off the Cloudways CDN, which is a major problem for us, but we are stuck if we keep Breeze running because we know it will break the site again. Even just disabling the Breeze plugin, it still creates files in the cache directory!! It has to be deleted altogether.

    Thread Starter 123host

    (@123host)

    I stopped using breeze as they don’t seem to be able to solve this. There are better alternatives out there.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.