• Resolved kubec

    (@kubec)


    Hi,

    I currently start using Breeze and Weglot plugins for a multilingual website, but I am having problem while Breeze plugin is activated. The button for switching between languages is not working. I hear that this is a pretty common issue when having caching plugin and using a multilingual or multicurrency plugins. Could you please help me with solving this issue? Thank you!

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author adeelkhan

    (@adeelkhan)

    Could you please confirm if is there any console error while clicking on the button to switch languages?

    Similar problem here.
    When I switch from source (Dutch) to destination (French) with “flag” button, the site shows French with url *.*/fr/
    But when switching back to Dutch with url *.*/ the site stays French.
    Only disabling Breeze helps, so Breeze has problems seeing the different URL’s that Weglot is making.

    Thread Starter kubec

    (@kubec)

    Hi,

    Yes, there are some console errors, here is screenshot: screen

    Plugin Author adeelkhan

    (@adeelkhan)

    Basically while selecting/fr/ french it is cached by Breeze.
    After that language change, it shows the cache version of the webpage(which is not correct)
    It needs to make compatible Breeze with weglot.
    we have added it to our task list and will fix it in our upcoming releases.

    Thanks, it would be great to have this fixed.

    Strangely enough only the first time when loading the / site, you can see the original language. So I would have thought Breeze should have cached this.
    But it obviously caches the translated language /fr/ and doesn’t notice the difference anymore when trying to view the / url again.

    Looking forward to the fix.

    Bert

    Hi, we also having this Problem.

    Is there a solution?

    Not yet.
    This is the answer I received at 25th September:

    We tested the cache plugin setup but the issue persists, which is why we escalated this case to the breeze plugin team to check this at their end.

    As soon as we get any update from them, we will update you to keep you in the loop.

    Plugin Author adeelkhan

    (@adeelkhan)

    The fix will push in our upcoming release.

    Plugin Author adeelkhan

    (@adeelkhan)

    The issue has been fixed in 2.0.11.
    Kindly update.

    Tested, and works fine now!

    Thread Starter kubec

    (@kubec)

    `Hi, thank you. I checked it and I see that the original problem is resolved. However, I am seeing another issue. When your plugin is on, woocommerce pages look weird – the product picture is huge, takes up the entire page. There is the picture when your plugin is off – https://gaiastore.eu/wp-content/uploads/2022/11/stimulanty.normal.jpg

    and when the plugin is on –
    https://gaiastore.eu/wp-content/uploads/2022/11/stimul.weird_.jpg

    You can see, that when the plugin is on, the currency switcher widget is also somehow broken. However, when I click on it and choose some currency, the website address switch from /category/stimulants/ to /category/stimulants/?currency=CZK (or EUR) and the visibility of woocommerce pages is now correct.

    So I guess the currency switcher plugin causes it. I am using WOOCS. In the setting of this plugin, I set that I am using a cache plugin. However, I am still having this issue.

    Thank you for any support!

    • This reply was modified 1 year, 7 months ago by kubec.
Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Breeze and Weglot – multilanguage website problem’ is closed to new replies.