Google Webfonts For Woo Framework
[resolved] Breaks WP 3.5.1 (11 posts)

  1. dub_xion
    Posted 2 years ago #

    Hey, I install it and I get a

    Fatal error: Cannot use object of type WP_Error as array
    error. Installed locally using MAMP.


  2. Jason Judge
    Plugin Author

    Posted 2 years ago #

    Was there any line number with that error message? When does the error happen - the moment you install it, or when you go to the settings page? Or perhaps only after you have entered the API key?

    It's one I haven't seen before, and is not reproducible on my 3.5.1.

  3. dub_xion
    Posted 2 years ago #

    Here's the full error (path excluded). Looks like line 180:
    Fatal error: Cannot use object of type WP_Error as array in /Users/.../wp-content/plugins/google-fonts-for-woo-framework/google-webfonts-for-woo-framework.php on line 180

    This comes up as soon as I enter the API key on the plugin settings and click "save", and I get the same error trying to access the plugin admin page. I have to delete the plugin dir to get things to work again. I have deactivated all other plugins.


  4. Jason Judge
    Plugin Author

    Posted 2 years ago #

    Thanks, that was useful. It was failing on fetching the fonts from Google. I don't know why it would fail, but I wasn't handling the error very well.

    The new version 1.1.0 will catch that error now and display it at the top of the admin pages. It it not going to directly solve your problem (not being able to use the new fonts) but it will at least give us the means to diagnose the problem.

  5. dub_xion
    Posted 2 years ago #

    Ok, installed 1.1.0 and it's giving this error:
    Error fetching Google font: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    I guess something with my API settings maybe?

    Thanks for the fast communication.

  6. Jason Judge
    Plugin Author

    Posted 2 years ago #

    Searching Google, it seems to be an issue with the way SSL certificates are handled by your web server. Do you happen to be running under Windows?

    Similar errors:


    This looks promising:


    That leads to this set of instructions and suggestions:


    It is all technical, and concerns the web server you are running on. I'm not sure there is a way around this in PHP. If this is not practical to fix, you may need to wait for a future version of this plugin where I will be putting in an up-to-date list of Google fonts so the list of fonts is relatively current even before you enter an API key.

    Sorry it does not look like a simple solution, but hopefully 1.1.0 is at least not breaking your WP installation.

    -- Jason

  7. dub_xion
    Posted 2 years ago #

    Hi Jason,

    Thanks for your response. I'm running MAMP locally on a MacBook, so that's probably the issue. I'll make do with the current font selection for now, then get the plugin going when I upload the site to an online server.

    Thanks again for your responsiveness!

  8. Jason Judge
    Plugin Author

    Posted 2 years ago #

    Of course, you did already tell me it was a MAMP server - got my head in the clouds. It looks like a well-known problem, and people who know more than me about such things have described some simple steps to fix it:


    Also happens with Ruby, but the solution may give some additional clues:


    Also Moodle, which points to this fix:


    The bottom line, is that Google is using an SSL certificate for its SSL connection. That certificate is part of a chain of certificates that feed back to the ultimate authority on all certificates in the chains it is the head of. What is missing from your installation of Curl, is one of the intermediate certificates; it should be installed on your server. The list is constantly updated, and so many servers are out-of-date. Most web servers get frequent enough updates to keep up however. It is all about how up-to-date the software is on your machine, but you can also manually install those intermediate certificates that you need. That last link shows how to do that (you will need a command-line window to issue a few short commands, and it should be done).

    Best of luck :-)

  9. Jason Judge
    Plugin Author

    Posted 2 years ago #

    Are you happy to set this to resolved? It's a problem with the server configuration, with known solutions, and nothing that can be worked around in PHP, WordPress or this plugin.

  10. dub_xion
    Posted 2 years ago #

    Yes, thx for the info on everything. Haven't had a chance to make those changes yet, but I'll mark the issue as resolved. Thanks for your help!

  11. dub_xion
    Posted 2 years ago #

    Just a quick question: for the first fix from http://curl.haxx.se/docs/sslcerts.html, I've got 7.20.0 on Mac, which is the best file to download from http://curl.haxx.se/download/ ?


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Webfonts For Woo Framework
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.