WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Breaks WordPress 3.7

[Resolved] Breaks WordPress 3.7

  • Fatal error: Call to undefined function wp_get_current_user() in /wp-includes/user.php on line 215

    I upgraded to WordPress 3.7, and when logging in to Admin I get this error message. Deactivating all plugins fixed it. Reactivated plugins one by one until I hit Reed Write and it breaks again. Please fix. I have multiple sites running Reed Write and I can’t upgrade until its fixed.

    http://wordpress.org/plugins/reed-write/

Viewing 12 replies - 1 through 12 (of 12 total)
  • I found this fix. Just add the following to the top of reed-write.php:

    //Fix WordPress 3.7 crash
    if( !function_exists( 'wp_get_current_user' ) ) {
        include( ABSPATH . "wp-includes/pluggable.php" );
    }

    Now if the plugin author would just push this out as an update I could have all my sites fixed all at once.

    Plugin Author iambriansreed

    @iambriansreed

    Since you asked so nicely; give me day; and look for the update.

    Awesome, glad to see you’re still around. One of the best plugins, I wish you kept developing it more.

    I wrote a custom field type on one of my sites and every time I update the plugin it gets deleted from the field_types folder. Would be great if there were a way to prevent this.

    It’d actually be better to delay the functionality that’s trying to use wp_get_current_user until init if possible. By including the pluggable functions in advance, you’re apt to break other plugins that may want to override them as well.

    Hi all – just seeing this. In another thread, someone said they had traced the same error to NextGEN Gallery. I haven’t seen any confirmation on that, and based on the above, this may not be related. But just FYI, I’ll also pass this thread and details to our developers. If anyone finds any connection to the NextGEN Gallery plugin, please let us know. Thanks! (Erick)

    @austen Blokker: by the way, thanks very much for posting a fix here that seems to be working for people. That’s always great to see. (Erick)

    @george Stephanis You’re probably right, I’m sure my fix is more of a hack and not the proper way to fix it.

    @photocrati I don’t have NextGEN Gallery installed on my sites, the issue for me lies solely with Reed Write. But I’m sure the same issue is cropping up in other plugins too.

    Thanks guys. I don’t have Reed-Write but someone mentioned NextGen and I have that so I disabled the NextGen folder inside the Plugin directory by renaming it to NextGen_paused and then refreshed the browser and my site was back up.

    Hope this helps…

    @bentot: We have had several users report a connection to NextGEN, but as far as I can tell, all were using older versions. Can you confirm if you were using 2.0.33 vs an earlier version between 2.0.0 and 2.0.30?

    Right now, it appears that if you update NextGEN to the latest version, you won’t see this issue. But we’d like to confirm that if possible.

    WordPress 3.7.1 seems to fix this fatal error in Reed Write.

    •Avoid fatal errors with certain plugins that were incorrectly calling some WordPress functions too early.

    Looks like it was affecting some other plugins too. This fixes my original issue with Reed Write so I will mark this as resolved.

    Yes mine is the old version that I didn’t update. Thanks

    The fix, by the way, will break certain mail apps.
    http://wordpress.org/support/topic/conflict-with-wpmandrill-plugin?replies=8

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Breaks WordPress 3.7’ is closed to new replies.