Support » Plugin: pagebar » breaks with some custom code in my functions.php

  • Resolved Ovidiu

    (@ovidiu)


    I use this code in my functions.php to create a meta box where I can enter custom CSS for each post separately. If I uncomment the line below pagebar shows the pagebar twice. Any idea where the problem lies?

    //Custom CSS Widget
    add_action('admin_menu', 'custom_css_hooks');
    add_action('save_post', 'save_custom_css');
    //add_action('wp_head','insert_custom_css');
    
    //custom CSS Widget
    function custom_css_hooks() {
    add_meta_box('custom_css', 'Custom CSS', 'custom_css_input', 'post', 'normal', 'high');
    add_meta_box('custom_css', 'Custom CSS', 'custom_css_input', 'page', 'normal', 'high');
    }
    function custom_css_input() {
    global $post;
    echo '<input type="hidden" name="custom_css_noncename" id="custom_css_noncename" value="'.wp_create_nonce('custom-css').'" />';
    echo '<textarea name="custom_css" id="custom_css" rows="5" cols="30" style="width:100%;">'.get_post_meta($post->ID,'_custom_css',true).'</textarea>';
    }
    function save_custom_css($post_id) {
    if (!wp_verify_nonce($_POST['custom_css_noncename'], 'custom-css')) return $post_id;
    if (defined('DOING_AUTOSAVE') && DOING_AUTOSAVE) return $post_id;
    $custom_css = $_POST['custom_css'];
    update_post_meta($post_id, '_custom_css', $custom_css);
    }
    function insert_custom_css() {
    if (is_home() || is_page() || is_single()) {
    if (have_posts()) : while (have_posts()) : the_post();
    echo '<style type="text/css">'.get_post_meta(get_the_ID(), '_custom_css', true).'</style>';
    endwhile; endif;
    rewind_posts();
    }
    }

    http://wordpress.org/plugins/pagebar/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Ovidiu

    (@ovidiu)

    screen shot: http://screencast.com/t/2dtnqKawkC2

    I set up pagebar to display below posts. What you can’t see in the screen shot is that the pagebar is displayed twice: as setup and as seen in the screen shot on top.

    Ovidiu

    (@ovidiu)

    Ok, solved, sorry for bothering anyone.
    I removed is_home() and it now works as desired, besides I don’t need to show/use custom css on the homepage.

    if (is_home() || is_page() || is_single())
    changed to
    if (is_page() || is_single())

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘breaks with some custom code in my functions.php’ is closed to new replies.