Support » Plugin: WebMan Amplifier » BREAKS Visual Composer Front End

  • dkurth

    (@dkurth)



    This plugin breaks the ability to display the visual composer front end.

Viewing 1 replies (of 1 total)
  • Plugin Author WebMan Design | Oliver Juhas

    (@webmandesign)

    Hi,

    Thank you for your opinion.

    Indeed, this is the case. Visual Composer does not handle custom WebMan Amplifier shortcodes properly in its front end editor and that’s why WebMan Amplifier disables the Visual Composer front end editor.

    I’ve looked into the Visual Composer code now, and unfortunately, there is no option to override disabling front end editor in the plugin… (and I’m not surprised).

    I’m currently working on a new version of WebMan Amplifier plugin, but have no ETA yet. I will introduce an easy filter to re-enable the Visual Composer front end editor. Or I will test it again to see if it got any better and make it enabled by default. Meanwhile the only way to re-enable it is to edit the plugin file webman-amplifier/includes/shortcodes/class-shortcodes.php (in your WordPress websites’s wp-content/plugins/ folder) and remove (or comment out) the code on line number 1471 -> https://github.com/webmandesign/webman-amplifier/blob/1.5.0/includes/shortcodes/class-shortcodes.php#L1471 (remove the vc_disable_frontend(); code).

    Also, please note that Visual Composer compatibility in this plugin is kept as legacy only. WebMan Amplifier (and Mustang theme – I presume you are using that one) works perfectly fine with Beaver Builder, which is much better coded and altogether much better page builder plugin in oppose to Visual Composer.

    Regards,

    Oliver

Viewing 1 replies (of 1 total)
  • The topic ‘BREAKS Visual Composer Front End’ is closed to new replies.