Support » Plugin: Podlove Podcast Publisher » Breaks some major details

  • Looks pretty cool and comes with a great mp3 player. BUT had some conflicts with Yoast SEO that kept the links from showing up with the featured image and snippet in social media. I figured out how to configure things so that they worked together and thought things were great.

    THEN I noticed that the podcast feed was broken. It kept throwing the feed into a redirect loop or redirecting to the home page. This was despite disabling all other plugins and changing the theme to Twenty Seventeen. Couldn’t ever get that ironed out so I gave up on it.

    UPDATE: Changing my review. I solved the YOAST SEO conflict by unchecking the Open Graphs setting in Podlove > Modules.

    The feed issue was caused by server-side caching, CDN and the Let’s Encrypt SSL certificate. I disabled the certificate and that corrected the issue. (There is a setting in Podlove > Expert Settings that can help with this but I had to just disable the certificate). There are A LOT of little things that you can adjust with this plugin. That means you might need to take your time and review all of the setting carefully. Once you’ve got everything dialed in it’s great but I’m not sure why Powerpress was able to create a valid feed with my server configuration but Podlove was not.

    • This topic was modified 1 year, 8 months ago by  mcmahant.
    • This topic was modified 1 year, 8 months ago by  mcmahant.
    • This topic was modified 1 year, 8 months ago by  mcmahant.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Eric Teubert

    (@eteubert)

    Hi there,

    Sorry you had to go through such troubles.

    Would you mind elaborating on the Yoast SEO incompatibilities? Since you managed to fix it, maybe there is a way for me to patch it so everyone can benefit.

    I have not encountered the feed redirect issue you describe yet. If you still have the system running, I would like to have a look. But in case you already moved on, never mind 🙂

    Best Regards, Eric

    Sorry I moved on and can’t remember the exact fix to repair the conflict with Yoast SEO. It was in the advanced settings and there was a check box that was set by default that I unchecked. It had something to do with the preview image and snippet.

    I updated my review with additional information

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Breaks some major details’ is closed to new replies.