Support » Plugin: Duplicator - WordPress Migration Plugin » Breaks sites after duplication

  • Resolved Maria Skatova

    (@justtralala)


    Hi, I have the same issue with two websites this week. I used duplicator for sites launch from dev to the main domain dozens of times and never had issues before. Now have the same problem with two different sites, transferred to different hostings.

    1. Themes options and settings are not transferred – themes go to default set up, custom css is lost
    2. Structure of permalinks changes from postname to custom, and the plugin adds some long line of numbers as part of that custom permalink – as a result, nearly all links of the site are broken.
    3. Percentage symbol – % – gets replaced by the same strange long line of numbers, and it breaks all CSS values with % on pages, built with page builder.

    Technically, it leads to reconfiguring theme and every page manually, using search regex for replacing that strange numbers with % again etc. Once flawless launch experience became a nightmare.

    The two sites I have problems with, use the latest versions of WordPress and all plugins, use different themes. However, both themes use Visual Composer for a builder.

    I already fixed them, but still have packages for both sites and can make a ‘broken’ one for experiment purposes if you like.

    I do love Duplicator and use it a lot and hope that’s something that can be fixed

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @justtralala,

    If you want to submit a support ticket for this issue I can have a closer look at your setup. Please provide a link to this thread when submitting the ticket.

    Thanks~

    Exactly the same issue here too

    If I try to migrate the database using WP Migrate DB it all went well instead.

    Also with duplicator worked without issues until a few days ago.

    I have the same problem reported by justtralala:
    permalink changed by numbers;
    themes lose settings;
    etc ..

    the strange thing is that old backups are installed without errors in localhost.
    The strangest thing is that the duplicator version is the same.
    Then if backup is done from site to localhost and reset, always in localhost, everything works.
    Do you have to change the php version?
    The problem is the new version of WordPress 4.8.3?
    it seems to me a problem of tables.
    I was going to buy the pro but now …….
    We ask for a helpooo solution 🙂

    • This reply was modified 3 years, 1 month ago by 78misterpc.

    @corylamleorg

    thanks I submitted a ticket

    NguyenDiep

    (@nguyendiep208)

    Please check your plugin and fix it, our team have the same problem

    I have the same problem using plugin on local host.
    Before authors will fix it, you can manually change database in package. Find a word “permalink” and there you’ll find those strange couple of symbols. Change all of them to percentage symbol and then install package, it worked for me.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Thanks for the feedback everyone! If someone can give the developer version a try it should have the updates for this issue. The very latest version (1.2.27) can be found by following these instructions:

    Download Developer Version
    – Uninstall your current version and install this one.

    Let me know if this solves the issue~

    Thanks

    @corylamleorg
    I’ve tried this version and the permalinks problem is solved, but all the plugins, exept Duplicator, were deactivated after migration with “wrong header error”. But it seems, that it’s because it’s developer version. Waiting for full bugfix and correct version of plugin. Thank’s for fast reaction!

    Hi guys,
    till then check Settings / Permalinks in WP Admin. You can set it there after site duplication.

    • This reply was modified 3 years, 1 month ago by halucska.

    I’ve tried the version, a fatal error occured on opening the wp 4.7.7 dashboard (wp-admin):

    Fatal error: Uncaught Error: Class ‘DUP_PRO_DB’ not found in H:\xampp70\htdocs\testdomain\wp-content\plugins\duplicator\classes\class.db.php on line 161

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hi @marsuby,

    Sorry about that the branch got messed up. This version should be good
    Download Developer Version it will show as 1.2.28 but is still in the dev line.

    @shustoff Your issue should be addressed as well.

    Thanks for helping out~

    I’ve resolved going back to version 1.2.24. backed up two different sites and restored the localhost. everything seems to work. Congratulations to the plug-in these are things that can happen, a plug like duplicator I still did not find it 😉
    Good job

    @corylamleorg

    Hi Cory,

    I’ve just tried the developer version (1.2.8). It worked well, everything seems fine.

    I totally agree to @78misterpc, those things happen. WordPress is an evolving and permanently changing environments, side affects may occour. It’s an architecture not always easy to cope with.

    thanks – well done, great support

    • This reply was modified 3 years, 1 month ago by marsuby.
    Plugin Author Cory Lamle

    (@corylamleorg)

    Thanks for the feedback and time to test! I’ll try and get the next version out shortly…

    Following this thread – we’re using Headway and are loosing Headway settings, CSS etc after migration.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Breaks sites after duplication’ is closed to new replies.