Support » Plugin: External Links - nofollow, noopener & new window » Breaks post save in WP 5

Viewing 13 replies - 1 through 13 (of 13 total)
  • True. Was wondering what was causing that. Just to find it is this plugin.

    This is true. Although it does actually save the post even though it throws up the “failed” message.

    Shame the plugin developer let this one die, this was useful πŸ™

    Plugin Author WebFactory

    (@webfactory)

    Hi guys, the plugin is not dead πŸ˜‰

    A new version will be available next Monday with all the bugs fixed. Thank you for using it and being patient πŸ‘

    Plugin Author WebFactory

    (@webfactory)

    Hi,

    Unfortunately, I can’t replicate this error in the classic editor or Gutenberg. Can you please provide some more details? Or perhaps copy/paste your plugin settings. You can find an export in the Support tab. Thank you!

    Upward Creative

    (@upward-creative)

    WPEL Settings:
    array(
    ‘wpel-external-link-settings’ => array (
    ‘apply_settings’ => ‘1’,
    ‘target’ => ‘_blank’,
    ‘target_overwrite’ => ‘1’,
    ‘rel_follow’ => ”,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ”,
    ‘rel_external’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ‘fa icon-external-link’,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ‘dashicons-menu’,
    ‘icon_fontawesome’ => ‘fa-500px’,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-internal-link-settings’ => array (
    ‘apply_settings’ => ‘1’,
    ‘target’ => ‘_self’,
    ‘target_overwrite’ => ‘1’,
    ‘rel_follow’ => ”,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ”,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ‘dashicons-menu’,
    ‘icon_fontawesome’ => ‘fa-500px’,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-excluded-link-settings’ => array (
    ‘apply_settings’ => ”,
    ‘target’ => ”,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ”,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ”,
    ‘icon_fontawesome’ => ”,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-exceptions-settings’ => array (
    ‘apply_all’ => ‘1’,
    ‘apply_post_content’ => ‘1’,
    ‘apply_comments’ => ‘1’,
    ‘apply_widgets’ => ‘1’,
    ‘skip_post_ids’ => ”,
    ‘ignore_classes’ => ‘nc_tweet,swp_CTT’,
    ‘subdomains_as_internal_links’ => ‘1’,
    ‘include_urls’ => ”,
    ‘exclude_urls’ => ”
    ‘,
    ‘excludes_as_internal_links’ => ”,
    ‘ignore_script_tags’ => ‘1’,
    ‘ignore_mailto_links’ => ‘1’,
    ),
    ‘wpel-admin-settings’ => array (
    ‘own_admin_menu’ => ”,
    ),
    );

    Plugin Author WebFactory

    (@webfactory)

    Thank you πŸ‘πŸ»
    You’re using classic editor or Gutenberg?

    Upward Creative

    (@upward-creative)

    You’re welcome

    I’m using Gutenburg

    Thanks for updating the plugin

    Look forward to the new version

    Plugin Author WebFactory

    (@webfactory)

    After another 2 hours messing with this, with your settings on a clean installation, I still can’t get the error to show πŸ™ Can you please email us at support@webfactoryltd.com so that we get to the bottom of this. I’d really love to squash the bug but need to replicate it first. Thank you! πŸ™‡β€β™‚οΈ

    politicske

    (@politicske)

    These are my settings. Tried the plugin again and the issue persists. Mostly when trying to update an existing post. Using Gutenburg editor on latest version of wordpress. It is not a plugn conflict coz the issue still shows even with all plugins except this one disabled.

    WPEL Settings:
    array(
    'wpel-external-link-settings' => array (
      'apply_settings' => '1',
      'target' => '_blank',
      'target_overwrite' => '1',
      'rel_follow' => 'nofollow',
      'rel_follow_overwrite' => '1',
      'rel_noopener' => '1',
      'rel_noreferrer' => '1',
      'rel_external' => '1',
      'title' => '{title}',
      'class' => '',
      'icon_type' => '',
      'icon_image' => '1',
      'icon_dashicon' => 'dashicons-menu',
      'icon_fontawesome' => 'fa-500px',
      'icon_position' => 'right',
      'no_icon_for_img' => '1',
    ),
    'wpel-internal-link-settings' => array (
      'apply_settings' => '1',
      'target' => '_self',
      'target_overwrite' => '1',
      'rel_follow' => '',
      'rel_follow_overwrite' => '',
      'rel_noopener' => '1',
      'rel_noreferrer' => '1',
      'title' => '{title}',
      'class' => '',
      'icon_type' => '',
      'icon_image' => '1',
      'icon_dashicon' => 'dashicons-menu',
      'icon_fontawesome' => 'fa-500px',
      'icon_position' => 'right',
      'no_icon_for_img' => '1',
    ),
    'wpel-excluded-link-settings' => array (
      'apply_settings' => '',
      'target' => '',
      'target_overwrite' => '',
      'rel_follow' => '',
      'rel_follow_overwrite' => '',
      'rel_noopener' => '1',
      'rel_noreferrer' => '1',
      'title' => '{title}',
      'class' => '',
      'icon_type' => '',
      'icon_image' => '1',
      'icon_dashicon' => '',
      'icon_fontawesome' => '',
      'icon_position' => 'right',
      'no_icon_for_img' => '1',
    ),
    'wpel-exceptions-settings' => array (
      'apply_all' => '1',
      'apply_post_content' => '1',
      'apply_comments' => '1',
      'apply_widgets' => '1',
      'skip_post_ids' => '',
      'ignore_classes' => '',
      'subdomains_as_internal_links' => '',
      'include_urls' => '',
      'exclude_urls' => '',
      'excludes_as_internal_links' => '',
      'ignore_script_tags' => '1',
      'ignore_mailto_links' => '1',
    ),
    'wpel-admin-settings' => array (
      'own_admin_menu' => '',
    ),
    );

    Edit: Seems for me the problem is a conflict with WP User Avatar Plugin. Install the two and see if the error appears in Gutenburg editor.

    Plugin Author WebFactory

    (@webfactory)

    Thank you for the info!! I’ll try with User Avatar ASAP as I really wasn’t able to replicate on a clean install with no other plugins πŸ‘

    politicske

    (@politicske)

    Seems the new update has resolved the issue for me. Good to have this plugin back!

    Plugin Author WebFactory

    (@webfactory)

    So glad to hear that! πŸ‘πŸ‘ The plugin is definitely back πŸ™‚

    If you have a minute, please leave us a rating. Would really love for people to see we’re maintaining it again. Thank you! πŸ™ https://wordpress.org/support/plugin/wp-external-links/reviews/#new-post

    politicske

    (@politicske)

    The problem is back again. Could you check what the conflict is?

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.