Support » Plugin: Business Directory Plugin | GeoDirectory » Breaks Kadence Starter Templates Connection To Database

  • Resolved bradallenfisher

    (@bradallenfisher)


    When i install a fresh copy of GEO Directory and Kadence theme with starter templates, the site can’t access the template database.

    https://pasteboard.co/KfMzB3R.png

    Steps to reproduce.
    1. install kadence theme
    2. install kadence starter templates: /wp-admin/themes.php?page=kadence-starter-templates
    3. install geo directory
    4. go back to kadence starter themes: /wp-admin/themes.php?page=kadence-starter-templates

    Error, Unable to access template database, please try re-downloading

Viewing 10 replies - 1 through 10 (of 10 total)
  • Thread Starter bradallenfisher

    (@bradallenfisher)

    This is what is coming back in inspector. There are about 37 of these types of notices… not sure if it’s breaking js from loading the templates or what.

    blocks.min.js?ver=e2b6602c7ebbe8ce93832ce35d81be1c:2

    The block “geodirectory/geodir-widget-search” is registered with an invalid category “geodirectory”.

    Plugin Support alexrollin

    (@alexrollin)

    Hello,

    thank you for reporting, we are looking into the issue.

    Hi @bradallenfisher

    I checked it locally and could not face any such issue with the Geodirectory plugin.

    https://ibb.co/9Tf8yL8

    I will suggest you create a support ticket. https://wpgeodirectory.com/support/

    so our support team can check it closely and fix it.

    Regards

    Thread Starter bradallenfisher

    (@bradallenfisher)

    Thank you yes I have actually tracked this down to be specific to cloudways hosting platform. I can’t replicate the issue on my vagrant or linode environments either. I have put in a ticket with them but the problem is when I build the site on my local and import it I can’t replicate it that way either. It’s only when I create the site on the cloudways hosting platform that I have any issue.

    Since this is such an edge case, I’m going to just close this request.

    Thread Starter bradallenfisher

    (@bradallenfisher)

    Yes thank you but that didn’t fix it. I added the absolute path. The only thing that would make it work is if I built the site locally and then exported it up to cloudways. I have a feeling it has something to do with the way they’re using file system management. They’re using load balancers and probably some sort of NFS or file mount and I think it’s just getting mixed up when it’s trying to look for the json file.

    Plugin Author Paolo

    (@paoltaia)

    I could recreate this on Cloudways, the developer will do some testing and report back when they find a solution. Thanks for spotting this.

    Thread Starter bradallenfisher

    (@bradallenfisher)

    That’s great. I actually had them open up a ticket for me, but since I was able to get it working by doing the export from local they gave up on it saying that it wasn’t an issue… so I’m glad that you’ve opened it backup.

    Would you please do me a favor and update this ticket whenever they come up with a solution???that way I can stop using my work around.

    Plugin Author Paolo

    (@paoltaia)

    Yes, we’ll get back to you here…

    Hi @bradallenfisher,

    it should not depend on the plugin Geodirectory, more it seems like an issue of Kadence Starter Templates.

    Although I can’t reproduce it. we will try to check it with cloudways hosting platform.
    Could you please create a support ticket with staging details?https://wpgeodirectory.com/support/
    we will look at it and update you.

    Regards

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Breaks Kadence Starter Templates Connection To Database’ is closed to new replies.