Support » Plugin: WP Subscribe » Breaks Customizer

  • This plugin has broken access to the Customizer. Attempting to load the Customizer instead loads an unstyled widget edit page for the widget.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author MyThemeShop

    (@mythemeshop)

    Hello,

    I can’t seem to replicate the issue you are experiencing. We’re there any errors in your javascript console? (⌘ + Option + j).

    Thank you

    Thread Starter sdvorak

    (@sdvorak)

    No there are no errors in the console. This is occurring on a multisite instance. The screen that loads is only a snippet of html:

    <div id='widget-21_wp_subscribe-__i__' class='widget'>	<div class="widget-top">
    	<div class="widget-title-action">
    		<button type="button" class="widget-action hide-if-no-js" aria-expanded="false">
    			<span class="screen-reader-text">Edit widget: WP Subscribe Widget</span>
    			<span class="toggle-indicator" aria-hidden="true"></span>
    		</button>
    		<a class="widget-control-edit hide-if-js" href="/wp-admin/customize.php?return=%2Fwp-admin%2Fplugins.php%3Fplugin_status%3Dall%26paged%3D1%26s&editwidget=wp_subscribe-1&addnew=1&num=2&base=wp_subscribe">
    			<span class="edit">Edit</span>
    			<span class="add">Add</span>
    			<span class="screen-reader-text">WP Subscribe Widget</span>
    		</a>
    	</div>
    	<div class="widget-title"><h3>WP Subscribe Widget<span class="in-widget-title"></span></h3></div>
    	</div>
    
    	<div class="widget-inside">
    	<div class="form">	<div class="widget-content">	    	<div class="wp_subscribe_options_form">
    
            	<!-- Hidden title field to prevent WP picking up Title Color field as widget title -->
            	<input type="hidden" value="" id="widget-wp_subscribe-__i__-title" name="widget-wp_subscribe[__i__][title]">
    
    			
            <div class="wp-subscribe-label-field wp-subscribe-service-field">
                <label for="widget-wp_subscribe-__i__-service">
                    Service:            </label>
    
    			<div class="wps-input-wrapper">
    					<select class="widefat list-selectbox" id="widget-wp_subscribe-__i__-service" name="widget-wp_subscribe[__i__][service]">
    
    					<option value="aweber">
    				Aweber			</option>
    					<option value="feedburner" selected='selected'>
    				FeedBurner			</option>
    					<option value="mailchimp">
    				MailChimp			</option>
    			</select>
    	
    				
    				
    				
    			</div>
    
            </div>
    
            
            	<div class="wp_subscribe_account_details">
    
    									<div class="wps-account-details wp_subscribe_account_details_aweber" data-service="aweber" style="display: none;">
    						
    		<div class="aweber_authorization_area mb30">
    			<strong>To connect your Aweber account:</strong>
    			<br />
    			<ul>
    				<li><span>1.</span> <a href="https://auth.aweber.com/1.0/oauth/authorize_app/1afc783e" target="_blank">Click here</a> <span>to open the authorization page and log in.</span></li>
    				<li><span>2.</span> Copy and paste the authorization code in the field below.</li>
    			</ul>
    
    			<textarea rows="4" cols="80"></textarea>
    			<br />
    			<button type="button" class="button-primary aweber_authorization">Authorize</button>
    		</div>
    		<div class="alert alert-hint mb30  hidden">
    			<p>
    				<strong>Your Aweber Account is connected.</strong>
    				<a href="#" class="aweber_disconnect">Click here</a> <span>to disconnect.</span>			</p>
    		</div>
    			<input id="widget-wp_subscribe-__i__-aweber_consumer_key" name="widget-wp_subscribe[__i__][aweber_consumer_key]" type="hidden" value=""data-id="aweber_consumer_key">
    		<input id="widget-wp_subscribe-__i__-aweber_consumer_secret" name="widget-wp_subscribe[__i__][aweber_consumer_secret]" type="hidden" value=""data-id="aweber_consumer_secret">
    		<input id="widget-wp_subscribe-__i__-aweber_access_key" name="widget-wp_subscribe[__i__][aweber_access_key]" type="hidden" value=""data-id="aweber_access_key">
    		<input id="widget-wp_subscribe-__i__-aweber_access_secret" name="widget-wp_subscribe[__i__][aweber_access_secret]" type="hidden" value=""data-id="aweber_access_secret">
    		<input id="widget-wp_subscribe-__i__-aweber_account_id" name="widget-wp_subscribe[__i__][aweber_account_id]" type="hidden" value=""data-id="aweber_account_id">
    	
            <div class="wp-subscribe-label-field wp-subscribe-aweber_list_id-field">
                <label for="widget-wp_subscribe-__i__-aweber_list_id">
                    AWeber List            </label>
    
    			<div class="wps-input-wrapper">
    					<select class="widefat list-selectbox" id="widget-wp_subscribe-__i__-aweber_list_id" name="widget-wp_subscribe[__i__][aweber_list_id]">
    
    					<option value="none">
    				Select List			</option>
    			</select>
    	
    				 <button class="button wps-get-list">Get list</button>
    				
    				
    			</div>
    
            </div>
    
            					</div><!-- /wp_subscribe_account_details_aweber -->
    									<div class="wps-account-details wp_subscribe_account_details_feedburner" data-service="feedburner" style="display: none;">
    						        <div class="wp-subscribe-label-field wp-subscribe-feedburner_id-field">
                <label for="widget-wp_subscribe-__i__-feedburner_id">
                    Feedburner ID            </label>
    
    			<div class="wps-input-wrapper">
    
    					<input class="widefat" id="widget-wp_subscribe-__i__-feedburner_id" name="widget-wp_subscribe[__i__][feedburner_id]" type="text" value=""data-id="feedburner_id">
    	
    				
    				
    			</div>
    
            </div>
            					</div><!-- /wp_subscribe_account_details_feedburner -->
    									<div class="wps-account-details wp_subscribe_account_details_mailchimp" data-service="mailchimp" style="display: none;">
    

    I also have problems!

    When I go to Apperence – Customize I get this screen

    Edit widget: WP Subscribe Widget Edit Add WP Subscribe Widget
    WP Subscribe Widget

    Service:

    It´s works if I deactivate your program.

    Plugin Author MyThemeShop

    (@mythemeshop)

    Hello,

    Please let us know which versions of WordPress and PHP you are using so that we can try to replicate the issue on our end.

    Thank you.

    Thread Starter sdvorak

    (@sdvorak)

    I’m running 4.8.1 of WP in multisite mode and 1.2.3 of your plugin. PHP is at 5.3.3.
    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Breaks Customizer’ is closed to new replies.