Support » Plugin: StaffList » Breaking js error in WordPress 5.5

  • Resolved thomasprice61

    (@thomasprice61)


    When WordPress is updated from v5.4.2 to v5.5 the following javascript error occurs:

    Uncaught TypeError: this[binder] is not a function
    at n.fn.init.$.fn.tipsy (tipsy.js?ver=1.3:180)
    at build_stafflist (stafflist.js?ver=1:101)
    at HTMLDocument.<anonymous> (stafflist.js?ver=1:3)
    at i (jquery.js?ver=1.12.4-wp:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4-wp:2)
    at Function.ready (jquery.js?ver=1.12.4-wp:2)
    at HTMLDocument.J (jquery.js?ver=1.12.4-wp:2)

    This impacted other plugins.
    I had to disable StaffList as a workaround.

    The installed version of StaffList is 2.7.6

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author ERA404

    (@era404)

    Hello @thomasprice61

    Please check the quick patch in v.2.7.7
    The issue was caused by a deprecated listener function with the include Tipsy library.

    Reference, here:
    https://stackoverflow.com/questions/15473731/tipsy-live-does-not-work-with-jquery-1-9-0

    Let us know if this is all you need.

    ERA404

    Thread Starter thomasprice61

    (@thomasprice61)

    Hi ERA404
    Many thanks for your prompt resolution.
    All looking good now.

    regards
    Thomas

    Thread Starter thomasprice61

    (@thomasprice61)

    StaffList in the WordPress states:
    This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.
    From an initial test, StaffList is fine in WordPress v5.5.
    It would be great if the readme is updated:
    Tested up to:5.5

    regards

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Breaking js error in WordPress 5.5’ is closed to new replies.