WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Breakes With PHP 5.3

[Resolved] Breakes With PHP 5.3

  • mAsT3RpEE
    Member

    @mast3rpee

    Dear Sir,

    I am a web developer / designer / programmer who always has to fix your plugin every time it updates (my clients really like it). I always get the error

    fatal error: php cannot re-declare class mobile detect …

    I’m not trying to be a nuisance but will your code break if you include the class outside of a function that might be called twice thus breaking php. Or perhaps (and this is what I do) change the require line from require to require_once.

    The code I’m talking about is in q2w3-fixed-widget.php line 161:
    require ‘q2w3-mobile-detect.php’;

    Thank you

    http://wordpress.org/extend/plugins/q2w3-fixed-widget/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Breakes With PHP 5.3’ is closed to new replies.