Support » Plugin: Breadcrumb NavXT » BreadcrumbList shows double Name Attribute in Item (taxonomy = product_cat)

  • Hy,

    Thanks for the great Plugin! Configuring my breadcrumbs worked like a charm.
    I ran into Problems with the structured Data for google thou.

    This is my Breadcrumb Stucture:
    Startseite > Produkte > Vakuum-Heber > HOVAMAT VD 90°
    <Home> > <Post-Type> > <Produtct_cat> > <Product>

    It seems like something is wrong with the assemble_json_ld.
    I get a double name attribute in the last two items. On the third level, both of them are wrong. and on level 3 and 4 there is one name attribute each which has the complete breadcrumb template (with markup) in it.

    item	
      @type	
        Thing
      @id	
        https://www.hova.at/produkte/vakuum-heber/hovamat-vd90
      name	
        <span><a property='item' typeof='WebPage' title='Go to the Vakuum-Heber Produkt Kategorie archives.' href='https://www.hova.at/produkte/vakuum-heber' class='product_cat' bcn-aria-current><span property='name'>Vakuum-Heber</span></a><meta property='position' content='%position%'></span>
      name	
        HOVAMAT VD 90°

    Do you have any idea how that happens? I even tried to debug in the sourcecode of the plugin but without any success.

    https://imgur.com/a/SuAoJBV

    https://search.google.com/structured-data/testing-tool/u/0/?hl=de#url=https%3A%2F%2Fwww.hova.at%2Fprodukte%2Fvakuum-heber%2Fhovamat-vd90

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author John Havlik

    (@mtekk)

    By chance is product_cat a non-hierarchical taxonomy? That’s the only way I can think of that could result in the breadcrumb template ending up in a name. Unfortunately, the the way non-hierarchical taxonomies are handled is hacky (and not compatible with the display_json_ld function). Also, it doesn’t appear breadcrumbList supports multi-dimensional breadcrumb trails (which are to an extent are required for listing more than one non-hierarchical term in a breadcrumb trail). For the next release of Breadcrumb NavXT, I think I’m going to have that codepath check if there is only one term and, if so, do the same thing it does for hierarchical terms, which will not have this issue. In the meantime, if you have control over whether or not the product category is a hierarchical taxonomy, I suggest converting it to being a hierarchical taxonomy.

    drZivil

    (@drzivil)

    Hi John,

    I changed the taxonomy configuration to hirachical, and now it works.
    Thanks a million for your Help!

    cheers,
    Philipp

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.