Support » Plugin: WP Bitly » Branded link stop working

  • Resolved Granadamgt

    (@granadamgt)


    This morning we noticed that our banded links were not being generated. Jan. 25 was the last time this function worked. I have not changed any of the code on the site. The links stopped appearing in the Bitly dashboard as well as of Jan. 25. Does anyone have any ideas?

    • This topic was modified 1 year, 10 months ago by Granadamgt.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Temerity Studios

    (@temeritystudios)

    Hi @granadamgt,

    The plugin went unmaintained for some time, and was recently updated to work with Bitly’s current oauth implementation. The old apiKey method has been deprecated, however it may still have been working for installs that had retrieved a key before they disabled the old links.

    Have you checked the Writing Settings page to see if you are still authorized with your Bitly account? The button will be blue if not, and should be white if you are.

    Mine also stopped working after the latest update. I have reauthorized the plugin through the Dashboard > Settings > Writing but the issue still persist. Any help will be appreciated. Thank you.

    Plugin Author Temerity Studios

    (@temeritystudios)

    Awesome, so apparently we brought the plugin out of retirement only to wreak havoc!

    1) What method are you using to retrieve the shortlink? Admin bar, “Get Shortlink” next to the permalink, etc.

    2) Have you logged in to Bitly to verify if the shortlinks are being created and just not properly returned by the plugin?

    @temeritystudios thank you for the response. I cliced the blue authorize button it then takes me to the Bitly page. I then click allow and am logged out. I log back in and the authorize button remains blue.

    Yesterday was the last time the Bitly site created links for my posts.

    Plugin Author Temerity Studios

    (@temeritystudios)

    Sounds like we have two different issues going on here. @moviefloss, if I could ask you to start a new thread for yours, possibly with answers to the two questions I posed above, that would be great!

    @granadamgt, I wonder if one of your other plugins is reading one of the url parameters being sent back by Bitly.

    Could you go through the authorization process one more time and when you see the Bitly screen, copy and paste the URL here (there should be some data in the query string, I’m curious what your state and redirect_uri are showing up as).

    Plugin Author Temerity Studios

    (@temeritystudios)

    The issue appears to be a lack of base64 encoding on the state parameter. This is causing an issue on the verification server when it attempts to decode it.

    It looks like you’re hosting with Bluehost? The function that should be encoding the parameter is part of PHP core, unless they’ve done something to disable it. If you could get in touch with their support and confirm whether or not they know of any restrictions on base64 that would help us narrow this down.

    Thank you again. I will check with them now and post their response.

    They were not sure what you meant by base64. Should I be using certain version of PHP like 5.6 etc.?

    Plugin Author Temerity Studios

    (@temeritystudios)

    While I would recommend PHP 5.6 as the minimum you should be using, the plugin has been tested with PHP 5.2.4 and was working under that environment. I’m going to make some slight modifications to the authorization server and I’ll let you know when that is pushed up.

    I’m not sure why your copy isn’t encoding the state parameter as it should be, that’s a mystery I’d love to solve, but first I’d like to get everything working for you and then figure out the why of it as we go.

    Plugin Author Temerity Studios

    (@temeritystudios)

    Taking a little longer than expected to work out the issue here. After a careful review it looks like the authorization server is doing what it’s expected to do and we’re at a loss at the moment for why your instance is logging you out.

    If you’d be willing to let us take a closer look via your WP dashboard, please contact us at info@temeritystudios.com to privately exchange that information. If not, totally understandable and we’ll continue to try and work it out from this end. There’s already a new version in the works with some minor updates, and we’d love to have this issue worked out for that release.

    Plugin Author Temerity Studios

    (@temeritystudios)

    We just released version 2.4.1, which may not solve this issue immediately but there is now a setting on the options page to enable debugging.

    This will create a log file in /wp-content/plugins/wp-bitly/log/ — if after upgrading you’re still having issues authorizing, send me that file to info@temeritystudios.com and I’ll look for a permanent fix using the information provided!

    Plugin Author Temerity Studios

    (@temeritystudios)

    I clicked the new logo and then the authorize button. It then logged me out of my WordPress session. However, when I logged back in, the shortlinks appeared. Thank you very much for your help with this.

    Quoting this from the wpme shortlinks thread, I think you meant to post it here!

    I’m going to mark this as resolved since it seems to be working for you now. I’ll re-open if anyone else has an issue with being logged out. Looking at the API server logs, it appears all redirects are remaining intact so it might be another plugin or other issue causing the logout.

    Thanks for following up!

    Plugin Author Temerity Studios

    (@temeritystudios)

    Forgot to check the resolved box. 😛

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Branded link stop working’ is closed to new replies.