Support » Fixing WordPress » Brand new WP installation, same bug with 2 different themes

  • I am completly redoing two of my websites. For each website, I deleted everything—MySQL database and user, Addon Domain, all the files—and started from scratch with a brand new installation of WordPress. For these websites, I have two very reputable and premium themes—a different theme from a different developer for each website.

    Now, after installing the each theme, I install plugins and the following error appears:

    Warning: sprintf(): Too few arguments in /home3/[...]/public_html/[...]/wp-admin/includes/class-bulk-upgrader-skin.php on line 154

    The thing is that, with a brand new installation of WordPress and with two different themes and different plugins (also very reputable plugins), the exact same thing happens.

    What is the bug and how do I fix it?

    (See 2 posts bellow to see code of line 154 in the class-bulk-upgrader-skin.php file)

    • This topic was modified 4 years, 4 months ago by Kev5.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter Kev5

    (@kev5)

    /**
    	 *
    	 * @param string $title
    	 */
    	public function after($title = '') {
    		echo '</p></div>';
    		if ( $this->error || ! $this->result ) {
    			if ( $this->error ) {
    				echo '<div class="error"><p>' . sprintf($this->upgrader->strings['skin_update_failed_error'], $title, '<strong>' . $this->error . '</strong>' ) . '</p></div>';
    			} else {
    				echo '<div class="error"><p>' . sprintf($this->upgrader->strings['skin_update_failed'], $title) . '</p></div>';
    			}
    
    			echo '<script type="text/javascript">jQuery(\'#progress-' . esc_js($this->upgrader->update_current) . '\').show();</script>';
    		}
    		if ( $this->result && ! is_wp_error( $this->result ) ) {
    			if ( ! $this->error ) {
    				echo '<div class="updated js-update-details" data-update-details="progress-' . esc_attr( $this->upgrader->update_current ) . '">' .
    					'<p>' . sprintf( $this->upgrader->strings['skin_update_successful'], $title ) .
    					' <button type="button" class="hide-if-no-js button-link js-update-details-toggle" aria-expanded="false">' . __( 'Show details.' ) . '</button>' .
    					'</p></div>';
    			}
    
    			echo '<script type="text/javascript">jQuery(\'.waiting-' . esc_js($this->upgrader->update_current) . '\').hide();</script>';
    		}
    
    		$this->reset();
    		$this->flush_output();
    	}
    • This reply was modified 4 years, 4 months ago by Kev5.
    Thread Starter Kev5

    (@kev5)

    Code with line numbers:

    https://pasteboard.co/GC2YsrD.png

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Brand new WP installation, same bug with 2 different themes’ is closed to new replies.